how to suppress automatic adding to addressbook

How can I suppres that adresses of incoming mail are automatically added to my addressbook. Sometimes I get an e-mail with several recipients and then they all come into my addressbook, also e-mailadress of companies that send a confirmation or so. I would like to have my addressbook as clean as possible.
Piet de Geus,

Go to menu/tools/settings/mail/compose and under the "Recipients history’ section, uncheck “Store composed mail recipients for suggestion”.  You can also clear what has been saved thus far by clicking “Clear recipients history…”