How to remove signature from replies?

Hello! I’m using the free version with a Gmail account. I’ve synced my signature from Gmail and want it to appear only on new emails, not on replies. I’ve checked, and “Not selected” is the option I have selected under replies in the signature section. I’ve also checked my Gmail preferences, and everything is correct there, too. Deleting my signature from every single reply is driving me crazy…is there any way to fix this?