How to eliminate a superfluous recurrent notification

I trying out eM Client. I have my Gmail account set up so the “All Mail” folder is not available for synchronization, as I don’t need and don’t want to have everything in that folder downloaded. eM Client keeps giving me a pop-up notification that the “All Mail folder is disabled” and that it can’t synchronize it (see screenshot below). Any ideas about what I can do to eliminate this needless recurrent notification?


Hello Joshua,
with the improved synchronization for Gmail labels in eM Client 7, the All Mail label needs to be enabled in IMAP. That is the only way to get rid of this pop-up.

If you do not have the ‘Download all messages for offline use’ option enabled, eM Client will not download all of your messages to your computer.
eM Client only synchronizes email headers for IMAP accounts by default (unless the offline option is set) and only downloads the content of the opened message when asked for.


Thank you. I was initially hesitant to show “all mail” on the gmail imap side because I thought it would mean downloading a ton of stuff (particularly on my laptop, where I have less space, and which is a mac with a different email client). But I made sure that all of my settings download headers only, which won’t be a problem.