How to delete a Search Folder?

sorry if anyone has already did the same question, but I cannot find it in previous conversations.

I am using eM Client on a Mac Book Pro.

I have created different Search Folders with specific rules, then I would like to rid of them but it seems it is not possible. Using the CTRL+Click it doesn’t appear any contextual menù, I expected a button like delete or dismiss, and if I drag and drop the search folder in the Trash, there is an error message saying that I am deleting the folder and all the contents inside, which is not my aim.

Hope someone can help me.


To delete a Search Folder, right-click on the folder and choose Delete.

Thank you Gary, but it doesn’t work on Mac.
As I wrote, the same shortcut which is CTRL and click on the touchpad doesn’t work. 

Sorry Stefano, wasn’t concentrating there for a bit.

Hopefully another Mac user can comment and help you out.

Ok, it came out that on Mac the right button doesn’t work. I checked on an eM-Client in Windows and the right button opened many options. Basically, there is a bug for Mac users…

If you have a Pro License Stefano, please open a Support Ticket with eM Client to log the bug.

I do not have it. I would like to solve this problem before purchasing a Pro Licence…

Hello Stefano,

I just tried your reported behaviour but I must confirm that the two-finger click opens the context menu where you can delete the search folder.
Which eM Client version are you using on your Mac?


Dear Russel, 
I see. Then clicking with two fingers on the folders I opened the context menu… Which is totally odd to me.

Why did you overwrite Mac shortcuts? Usually, the context menu is opened by clicking once pressing CTRL as well, not for sure clicking with two fingers…
Anyway, thank you for letting me know this. Now I have solved it.