How do I stop meeting invitations being automatically accepted?

when I receive meeting requests they are automatically accepted and loaded into the calendar. the sender then assumes I have accepted the request when I have not.

 it is creating diary chaos as I am constantly apologising for meeting misunderstandings

Hi Kay, unfortunately there’s no setting for this in eM client, nothing that would allow us to automatically accept invites.
What mail service are you using? And what version of eM client are you currently using?

Thank you,