hide+device+name

When I send an email, recipients see my computer device name as the sender rather than my email address from where it’s coming.  How can I change that so my email address shows ast he sender rather than the device (computer) name?

Hello William, not quite sure what you’re referring to, can you please make sure your name is setup in the sender’s details in Tools > Accounts > your account > User Information. In this setting you can setup what your sender ID will be when sending or replying to e-mail using eM Client.

If the issue persists, please make a screenshot of the issue and submit it to us here on the forum.

Regards,