HELP! Can't send mail -- "Folder has been deleted"

I use em Client as front-end to my gmail. Everything has been working great. All of sudden I tried to send email and now I get this error:

   Can’t process message
Couldn’t process the message because the following error occurred. Consider selecting a different account to send messages from.

       Folder has been deleted.

I have tried the following:

  1. A different gmail account
  2. Deleted my gmail account and remade it
  3. Logging out and back into em Client
  4. Rebooting my system and em Client doing a check on the database.

Nothing is working. Please help.

I have just removed em Client and reinstalled it and the problem still exists. Please help before I go looking for another email system.  Thanks.

Hi Brian,
Have you tried to reproduce this issue via webmail? Gmail accounts should work in eM Client.
Also you can send logs and screenshot of the error, to copy logs go to Menu>Tools>Operations>Log and copy with Ctrl+A, paste to notepad, then send the file to [email protected].

Hi there, I’m having the same issue with one of our email accounts. Was this resolved? I would love to know how!

I’ve deleted the gmail, and re-added it and let it sync again. He can send emails through web gmail no problem.

I too have this problem. Is there a fix?

Hi there! No not entirely. I had to start a fresh database, and unfortunately had to lose everything that wasn’t on gmail. Even restoring from a backup caused the same problem.

Thanks for your comment. Not a good outcome at all. I have a lot that will be lost if that is the case . . .

My question remains: I can’t send emails from any of my accounts with the error message that the reason is “the folder has been deleted”. I will have to exit eM Client totally is can’t be fixed.

I have exactly the same problem. I can email from the Gmail site, and the email shows up in my emClient ‘Sent’ box. Is there a fix?

lunes 27 febrero 2023 :: 1600hrs (UTC +0100)

I am sorry I can not help you directly, you probably noted that this was an issue
several years ago - there was an intervention from eMC ([email protected])
then “nothing”. Was there a resolution?
The issue has occurred a number of times since, apparently with no fix…?

Do you use IMAP or POP3 with Gmail?


¡Saludos desde Valencia la soleada en España!

[email protected]

Hablo español, luego portugués e inglés, con conocimiento de varios otros idiomas.

I use IMAP. Is that important?


I am having the same problem, started out of the blue today. Was there ever a resolution that worked, preferably without losing data?

And so I am giving up on eMClient forever. It’s true that you get what you pay for.

Cannot send mail - folder has been deleted, sounds to me like something has happened to the local eM Client hidden mail database.

So if this just happened all of a sudden and you are not having any problems sending online, i would suggest to first normally try restoring a recent eM Client dated backup “prior to when this happened” via “Menu / File / Restore” (Pc) or “File / Restore” (Mac). That should then normally fix the issue if the mail database has become corrupted.

Now if you haven’t been backing up eM Client or don’t have a recent dated eM Client backup, then you will more than likely need to “create a new test database” to see if that resolves the problem.

So for a test, close eM Client and then rename your current eM Client hidden folder to eg: “eM Client-Old”. Then reopen eM Client and setup your account as new again and see if you can send email.

Hidden mail database folder Windows

“Users\yourusername\AppData\Roaming\eM Client”

Hidden mail database folder Mac

“Users\yourusername\Library\Application Support\eM Client”

Now if you are then able to send email with a new database and you had an IMAP, Exchange, Office 365 or iCloud account (and you had nothing in eM Client Local folders), then you can “just continue on with the new database” as all your messages and message folders will sync back from your mail server.

However If that still has the same problem with a new database, then something must have happened to eM Client program. So you would then next try uninstalling eM Client and delete the hidden database folder completely and reinstall eM Client program either from the Release history page or Windows store depending on what you had before. Then setup as brand new again.

Now for POP accounts “if you can then send ok with a new test mail database”, then you would close eM Client again, and then go back to the eM Client hidden folder where you will see the new eM Client folder and the eM Client-Old folder. So you would delete the new eM Client folder and rename the eM Client-Old folder back to eM Client. Then reopen eM Client to get back to where you started.

Next create a folder in “Local Folders” at the bottom left of eM Client called “Old Mail” and then drag / move all your current POP message folders as they are down under Old Mail. Then once you are certain all your POP messages and message folders are under Old Mail, remove your old POP account at the top and then re-add your POP account as new again via “Add Account / Mail / Other” option in eM Client accounts.

Then once your new POP is resetup again, drag / move all your Old Mail messages and message folders from Local Folders / Old Mail back up to the new POP account which should then fix it.

Lastly “before doing anything” make a manual backup of eM Client via “Menu / Backup” (Pc) or “File / Backup” (Mac) incase you need to restore if something goes wrong. You can see when the backup is complete in Show Operations via the dropdown on the right of Refresh at the top left.