Gravatar no longer works

My contacts with Gravatar avatars no longer display their image. Not quite sure when this started, currently on version 8.2.1721

I tried deleting the avatar cache, no help. After startup, the failed_requests.dat file is full of entries such as: gravatar_535a2c7c2c4b96b48d8ca7ff6077674c / 637979899468392023

Any ideas?

Looks like EmClient can no longer communicate over https to get the icons

HTTPS handshake to www.gravatar.com (for #18) failed. System.Security.Authentication.AuthenticationException A call to SSPI failed, see inner exception. < The message received was unexpected or badly formatted

Win32 (SChannel) Native Error Code: 0x80090326

lunes 05 septiembre 2022 :: 1921hrs (UTC +01:00)

Hey@Victor.David

I have more contacts with Gravatar avatars than I can be bothered to count, way in excess of 400 company colleagues, there are no issues on my system.
I am running eMC v9 on Win11 & v8 on Win10

¡Buena suerte!

¡Saludos desde Sevilla la soleada en España!

skybat

emc_forum@compucall.com

Hablo español, luego portugués e inglés, con conocimiento de varios otros idiomas.

1 Like

@Victor.David

Apart from deleting the avatar image cache, you can also force eM Client to “re-download your avatar” as per the following eM Client support article. The below worked for me previously" when i couldn’t get my Gravatar to show.

How to change my own email account avatar?
Posted by Olivia Rust on 24 May 2019 15:59

https://support.emclient.com/index.php?/default_import/Knowledgebase/Article/View/180/0/how-do-i-change-my-own-email-account-avatar

(Extract from the above support url)

IMPORTANT: Please note that since eM Client updates the downloaded avatars every 30 days, the avatar changes won’t be immediately visible.

However, you can force eM Client to re-download new images by disabling and re-enabling the download of images from external sources, which will clear the image cache:

Go to Menu > Settings > Contacts > General
Disable the option ‘Download avatars from external sources’ and click ‘Apply’
Then enable the option ‘Download avatars from external sources’ again and click ‘Ok’
Your new image will show up now

Note: I am using EMC V9.1.2109 and Windows 10 and 11 pcs.

@cyberzork Yep, tried all that, no go. :face_with_raised_eyebrow: I did discover however that the problem is not EMC itself, but rather the configuration of SCHANNEL on my Windows machine. I found a program that helps you with registry settings related to cipher suites, protocols, etc that are used by a .NET app.

https://www.nartac.com/Products/IISCrypto

I think what happened is that the Gravatar server stopped supporting an older protocol, and my machine couldn’t deal with it. At any rate, after configuring my machine, it’s now working again.

2 Likes