Google Account Contact Synchronization error with a non existing folder Contacts

The error seems to be related with Contacts synchronization with a Folder/Category called Directory that doesn’t exist in my Google GMail Account structure. The Google Account is not a general one, it belongs to Google Apps family account.

The error returned specifically is "Synchronization folder “[Account@domain]/Directory/’ failed diue to the following error: Execution of request failed … (Temporary problem - please try again later).”

Ive got exactly the same problem and error.

I was having this issue too (that’s why I’m here).  I found that you can right click on directory while in the contacts screen and just delete that folder.  If it doesn’t exist on your account then nothing is hurt.

It doesn’t work, after deleting it and restart emClient, the folder shows up again after the first sync

same for me, I already tried that and the folder is just re-created and I get the same error again. rather unbelievable that emClient support is totally ignoring the issue.

Sorry.  I hardly ever shut my em client down… I too am experiencing the folder coming back.

I tried upgrading to the beta version 7 but it has the same problem.
If I disable sync of Gmail contacts it fixes the problem but then of course I have no contacts. The only reason I use emClient is because it syncs everything from Google. If it no longer works I’ll have to find a better solution.

Still no response from support which is pretty poor. 

sorry for the delayed response, are you still experiencing this issue?
Can you try running repair on your Contacts folder? Open Contacts section, right-click your Gmail account and choose Properties>Repair. Run the repair and wait for a full resynchronization of the contacts to finish.
If this does not help, please try to remove your Gmail account from Tools>Accounts section and setting it up again.


no it doesnt work. I already tried that. I also tried reinstalling emClient still the same. There is a contact folder called “Directory” that causes the problem. This is for a Google Apps for Business using a paid version of emClient.

It doesn’t work. At all. It has been two weeks with this issue. I think this is entirely related to a new Directory structure on Google Apps contacts. Does anybody know a good alternative for emClient? This error is very annoying.

It seems they have no intention of solving the problem.

Do you all are experiencing this issue with a gmail account belonging to Google Apps? 

yes, using Google Apps for business.

Is the email you are using the Admin account on this Google Apps organization? I have Google Apps as well, and this is happening only on the Admin account, but not in other accounts.

Actually yes, mine is a Admin Account as well.

I tested using a normal account and I dont get any error. This only then happens when using a Google Apps account thats also the admin account.

Could you try with a non Admin account?

I did and it works fine. I can confirm it only happens to admin accounts.