GMail upload doesn't actually upload all mail

I’m trying to convert from an old email system, and the import worked great (yay!), but when I move the folders from the local folders list to my gmail account, it only uploads *some* of the emails.  Like one folder I have with over 2000 mails in it in eM Client, but if I go to the gmail web interface it only has 68!

eM Client tries to upload for a while and then just silently stops trying.  Further send/receive attempts do not appear to notice or try to correct the problem.


Hi Norma, what version of eM Client are you currently using? Are you seeing any errors from the application?


Wow, so it turns out i was totally wrong!

What’s happening is that it’s trying for a while and then timing our or failing or something (this is not surprising as our internet is *terrible*), but then on the next send/receive it tries again, at least enough of the time that things are sloooooooooowly uploading.

The reason I thought nothing was happening is that which folder it picks on a given run isn’t necessarily the same folder it picked to work on on the last run, so it appeared that the folder I’d just moved wasn’t being worked on, because it wasn’t; another folder was.

In addition, the behaviour when a folder is full of local files that are slowly being uploaded to gmail is quite seamless, it’s really good.

So, it’s doing fine!, just wasn’t doing what I expected (to wit: work on the most recently uploaded folder forever until done).

Thanks for the great product!  Now if only you could give me bigger icons for the taskbar.  ;(

Hi again, I’m glad things are not as bad as they looked like, what version of eM Client are you currently using?
If the connection gets dropped, eM Client should automatically reconnect to the server if possible with it’s next synchronization cycle.

Hope this helps,

Version 6.0.20648.0

I’ve found that sometimes I have to restart eM client to get it to continue uploading, but that’s fine.

Uh-oh.  I seem to have spoken too soon.

Now all send/receives complete, but the folders aren’t done.  As a for example, when I click on my ATFT folder, I get the “Synchronizing Messages” notification, and then it completes, but in eM it says “Total: 2111” in the bottom right, but in gmail the first page says “1-50 of 972”.

As far as I can tell, the numbers don’t match for any folder larger than about 100 messages.

Help, again?  Version 6.0.20648.0

The numbers don’t match between eM client and gmail because gmail is *counting threads*.

I turned off conversation view in gmail and it matches perfectly, and everything is there, and yay!

Sorry about all the confusion.

Hi again Norma, glad it workjs, let us know if you come across any other issues or questions, we’ll be happy to help.

Thank you,