Gmail online account sent message appears on my eM Client POP inbox

I’m hoping someone can help me with this. I have recently started using eM Client, and everything is working well. However, if I’m away from home and use my gmail account online (e.g. google chrome, firefox, edge, etc.), whenever I send an email, it shows up on my Inbox in eM Client which is set up as POP (I prefer POP over IMAP in my home setting for archiving copies in my own computer). This becomes particularly problematic when I have my Gmail vacation responder on, since every single email that gets an auto-reply of “I will be away…” will show up on my eM Client Inbox upon my return home. Is there any way to remedy this? Thanks.