Frequent "[IMAP] Cannot open folder..." errors in Beta version 8

After installing beta v8 I started getting very frequent (dozens of them daily) errors
“[IMAP] Cannot open folder /folder name…”. Version 7 did not do it and other email clients I use have no issues with the same mailboxes.
Reading what’s new in v 8 I found you have “Redesigned IMAP support” so I attribute this new errors to this redesign. Can you pls fix it or advise how to get around it? I tried every possible combination of IMAP settings but, sooner or later, the same errors start to appear again.
The emails still work (they come in and can be sent out) but once in a few minutes these errors just pop up.

Yes, unfortunately that is the nature of beta software. Sometimes it has so many bugs it is not even usable. Can you send your feedback to testing@emclient.com. You may also want to tell them which provider you are using.

In the mean-time, there are only two possible combinations for IMAP settings for port and security policy.

Port 993 = Use SSL/TLS on special port (legacy)
Port 143 = Use SSL/TLS if available

Hi Gary, thank you for your response. I tried both settings with the same result. I understand that beta software contains bugs and I’m fine with that - that’s whay we have beta’s. Just wanted to highlight this particual bug for case you were not aware of it yet from other users/testers. I will also report it to the testing email you provided.