Freezing issue and UI layout (language related)

Running the latest version of eM Client, here is how to reproduce the freeze issue:

  • Set Language to Russian.
  • Reply to any message. Reply window appears.
  • Click “Add CC & BCC”. 2 fields appear.
  • Minimize the Reply window.
    The application will freeze for some time (1-3 minutes), it will consume CPU and RAM resources until about 1.5 GB and then unfreeze. It will freeze again if minimized.

The freezing will not happen in any of these cases:

  • Language is set to English.
  • Window different from Reply window.
  • CC and BCC fields are hidden.

Another small language related layout issue:
With Russian language selected, in Send later window, due to long text, the time field is located partially out of border. Minutes are not visible, which makes it difficult to use.

martes 29 septiembre 2020 :: 1826hrs (UTC +01:00)

Здравствуй Andrew26…

Вы русский или как я умеете говорить на этом языке?

Anyway you made the post in English so I prefer to continue that way as it is some while since I used Russian on a regular basis and it’s a bit rusty

I have just tested your issue several times on a desktop and a laptop both running Windows 10 Pro, the laptop is new, a very high spec with 64Gb RAM, so perhaps not a fair test, and the desktop with a slightly above average spec and 32Gb RAM; I was not able to get either system to freeze in the Reply window - so perhaps this is system capability related.

However, I agree, the Russian text is so long that the ‘seconds’ are not accurately displayed, though they do work.

If this is a major issue you should make a report to the developers.

¡Saludos desde la soleada España!

Russ

emc_forum@compucall.com

I’m Russian but it shouldn’t matter.

I was able to reproduce the issue on Windows 7, 8.1 and 10, all with latest updates. On a more capable system with 32 GB RAM the freezing lasts for about 10 seconds, but the RAM consumption is still inadequate during that time. My guess is that if other people can’t reproduce it then it may also depend on OS locale (Russian in my case).

I don’t know how to report anything to developers, since I was redirected here when I select Get Support. I’m also not a Pro version user, so I can’t use the online support center.

This is not a major issue for me, but I thought I’d still report it since it could help other people if it’s fixed eventually.

martes 29 septiembre 2020 :: 1955hrs (UTC +01:00)

Hi Andrew26…

No, it certainly makes no difference to me, I was just concerned that I would make
a complete fool of myself with my very basic Russian - a few years ago I was in
Moscow for 3 years.

I understand what you are saying about RAM, on my systems I also have a
dedicated fixed size Paging Files, plus I also do this::
Run ->msconfig ->Boot ->Advanced options ->Check Number of processors at highest available ->
OK ->Apply ->OK ->Reboot
This forces the most available out of your system.

I’ll report the issue as you don’t have access from a Free license.

¡Saludos desde la soleada España!

Russ

emc_forum@compucall.com

I didn’t notice anything bad in your Russian.

This is most certainly unnecessary since it’s only for limiting the amount of cores available to the OS, for various diagnostic purposes. By default Windows uses all available CPUs and cores so there is no need to enable this option.

Thank you.