Formatting Signatures

eM Client is putting some odd formatting in my signatures - notably double line spacing. Even pasting it in from notepad doesn’t work.
Can anybody tell me how to get single line formatting please?

Pasting from the clipboard might include formatting, but probably not from notepad, or it could be that you are pasting into an already formatted paragraph. You could paste the text by right-click and choosing Paste as Text, and see if that changes anything, or you can right-click and choose More > Remove Format afterwards.

If you know something about HTML, you can right-click while editing the signature and choose Edit Source. That way you will be able to see the paragraph formatting.

Some clipboard caching apps might also affect this. I was using one text expander type app that sometimes added extra line breaks.

Gary - thank you that gave me several ideas!
I designed and formatted the signature in Word then copied it over and it retained the formatting I wanted.
Thanks again!

Glad you got it to work Jeff.

I have the same issue with Task Descriptions and eM Client on the Mac and even with copying a signature during migration from Outlook. 
“Remove Format” could be a solution but it seems this is not available on the Mac? I have no clue about HTML and would be happy to see a normal behaviour of eM Client like when pasting into other applications, e.g. Outlook.

I have in many task descriptions the issue that pressing enter will not only start a new line but it will insert an additional line. This might have to do with the fact that I tend to copy things into the task descriptions but from my point of view this should be normal and possible without such hassle.

I’ve only just started using EM Client but…
I suspect it’s creating a new paragraph. when you create a new paragraph in html using

it’s double spaced.
Maybe you could do your pasting as plain text?

I could, but every other software is capable to handle this in a simpler way.

I have tried every which way to create message rules, but am now slowly going insane! I have used Windows Live Mail and successfully created rules there, but this free EMC just refuses to play ball!!
Could someone please show me - picture speak louder than words - the sequence of moving a message from the Inbox to another folder. I can’t believe how difficult such a simply instruction is here!



Not to do with this thread Mike, but here is your answer:

Go to Menu > Tools > Rules.

Click on New Rule.

The very first option is to move a message from someone to a folder.

If that is what you want to do, click on people to enter the details then click on folder to select the destination. 

If you already have an email from that person, then just right-click on their name/address in the email header and choose Create Rule From.

Then select the folder.

Hi Gary,
Apologies for getting on the wrong thread. I eventually got what you mean by ‘the email from that person’. I used the email showing in the inbox, unopened. When I go via Menu/Tools/Rules, and it comes to tick the folder to copy to, each folder has a small box next to it. But when I right click on the message header (as you suggest) the folders do NOT have a box to tick. Strange, or what?!

In a nutshell, I have followed all the steps but it still doesn’t work. So, what now? Does the free version allow messasge rules?

Which thread do you suggest I use for this topic?


Because this thread is dealing with formatting of signatures, it would have been better to start a new one rather than asking an unrelated question in this thread.

The Free and Pro licenses are non-different as far as Rules go. Maybe post a screenshot of your Rule that is not working and let’s see if there is anything that can be done. Also, what version of eM Client and Windows are you using?

Hi Gary,
I have now moved to here….

Will reply there,