flagging incoming replies

If someone replies to my email without changing the title, their reply sits itself under my outgoing message - but there is no “unread” flag next to the message in the Inbox list (like the orange spot that tells me of new mails which are not replies.  Over the past weeks I have had people asking me why I am not responding to their responses.  This is embarrassing. 

Hello Robert,
the conversation is always showed in your inbox when there is a new reply and is marked as unread.
What version of eM Client are you using? Make sure you have the latest one from our website.

Also, I suggest perhaps changing your Conversation setting if you have hard time keeping with it - Menu>View>Conversations.