Exchange Sent Mail Shows Up Twice

Using EM7 Beta, with Exchange the sent mail is showing up twice in EM Client but not on my Exchange Server. This is messing with the conversations threading.

It look like when i send the mail it does what is supposed to do but then a few seconds later another copy of the sent mail shows up in the sent folder. However this is only present in EM Client. Not on the server.

The copy on the server is the one that was sent first (i checked the time stamps) and like i said, the second copy in EM Client is only on EM Client.

Hello Nick,

Can you check your rules in Menu>Tools>Rules if there are any rules that might cause this behaviour?
Thank you.


I have this, too. I have no ‘Rules’ set.

Any chance of a response to this…or do we just have to accept it as a known bug that will never be fixed?

Any news on this, as I’m still getting this problem, even with today’s update?

Hello Nico,
do you have the ‘Save a copy of sent messages in ‘Sent’ folder’ option in Tools>Settings>Mail>Send enabled?
Sounds like your server might have an explicit rule like that as well and both are applied, creating two copies of the message. Try disabling the option either in eM Client or on your server.


Hi Olivia, thanks for the suggestion - this has fixed the issue. I had to uncheck the setting in emClient, as Office 365 Exchange doesn’t seem to provide an option to do it at the server end! Anyway, thanks - emClient is working very well for me now.

Hello Nico,
glad to hear the issue is solved.


Hi Olivia, in fact this is NOT working properly. I cannot turn off ‘Save sent mail’ in emClient, because I have also an IMAP mail account. If I turn off ‘Save sent mail’ , my sent messages are not saved anywhere.

Would you please ask your developers to make ‘Save sent mail’ an option PER MAIL ACCOUNT, not global?

I second this, it should be possible to set it per account.
Have to repair the sent folders of all exchange accounts once a day to get rid of these annoying double entries.