Exchange EMail Gone/Re-syncing Stuck

So something new that just happened today on two of my machines. Nearly all of my email from my Exchange Server has disappeared on both machines. Just a preface, there’s some quirks to how our Exchange Server is set up, so it isn’t actually using the Exchange setup to sync email, but the Outlook client with our Exchange Server details - which was working up until today.

I’ve had eM Client running on one machine for quite some time, about a year. The second machine was added a few days ago. I had over 28k emails in my Exchange account, and it took eM Client about 3 days to do the initial download on this account on the first machine. In order to avoid that on the new machine, I copied the eM Client data folder from one machine to the other (all 12 Gigs). This worked fine until today.

The folder is still the same size (the file mail_data.dat being the largest file), but the new machine is stuck at 210 emails in the inbox while the old machine appears to be re-downloading everything (and starts from zero if the app is re-started).   

Hello Kurt, what version of eM Client are you currently using on your computer, can you please check the exact release number in Help > About? Are your messages still available on your mail server? What version of Exchange are you using on the remote server?

Are you seeing any errors thrown by the application when you try to synchronise your items?


Hi Paul,
The eM Client Version is 6.0.22344.0.
The Exchange version is
All of my messages are still on the server. 
There haven’t been any error messages.

Please try to update your eM Client to this release, 6.0.22930.0 and check if the issue persists.


Hi Paul,

I did the update and the issue still persists. But I think I know what is wrong and it has to do with how eM Client connects to our server and how our server is set up for security. Our Exchange server is only accessible when connected to our network either in the office or via VPN and is designed to work with Outlook, the server address is an intranet address as opposed to OWA. I started using eM Client because it is a desktop client that can use the same method a cell phone connects to our server which uses a different web address to access our server (by using the “Outlook Mail” profile with our external server address and not the Exchange Profile which only works as Outlook does using the intranet address while connected to our work network). On the server, any cell phone, tablet or other device is listed with it’s own unique identifier (Windows 8/10 mail also can connect the same way, basically using Activesync or whatever the new version of that protocol is called). Each device is listed so that it can be remotely wiped if it ever gets lost.

I decided to try and re-initialize eM Client on both of my machines and remove any traces of eM Client from the mobile device manager on the server. One thing I noticed is that eM Client was only listed once even though I had it running on two machines. Even my phone, which is a singular device had more than one listing based on if I had ever reinitialized the phone. Since the server only sees eM Client as one device, sync was screwed up. I confirmed this once I started syncing my work laptop and my home laptop and both machines could not sync at the same time - if one machine tried to sync the “Inbox” while the other machine was trying to do the same, each machine would constantly start over. When I quit eM Client on one machine or when syncing different folders, the other would sync just fine. The server sees eM Client as one device regardless of how many machines it is running on.

Is there a way to fix eM Client so that it can identify itself uniquely when running on more than one machine but connected to the same email account?

Hello, unfortunately ActiveSync configuration is not supported for Exchange connections  - what you’re describing is an unsupported case I’m afraid as it is not possible to connect to the “OWA” using VPN remote connections to internal access in your company.

ActiveSync is mostly used for mobile device connections, and even though there’s a workaround how to setup the account over AirSync this is basically strictly not recommended nor supported from our side, as it is not allowed to access the server this way from eM Client.