Exchange account mail not displaying in smart folder

Exchange account mail not displaying in smart folder after this morning’s EM update (6.0.20899.0). Doesn’t matter if it is set to default or not, only Exchange mail does not display. It displays fine in the normal inbox, just not the smart folder.

Restarting EM again seems to fix this problem.

Hi Chris, not completely sure if you’ve manage to resolve the issue or not, please let me know if you need my assistance in resolving the issue, I’ll be happy to help. If not, please let us know if you come across any other issues or questions, we’ll be happy to help.

Thank you,
Paul.

 I thought I had fixed it, but…

Well as it turns out, there is still an odd issue. One other thing I did try to do to fix this (before restarting the program), was changing the default account from my gmail to the exchange account.

That didn’t fix the problem. Restarting EM did. But the following day the gmail wouldn’t show up in the smart folder. Gmail is normally my default, so I switched the default back to gmail, restarted EM and now both accounts are showing up in the smart folders normally, just as they did after restarting EM the first time.

It’s fine now, but the fact that it happened again indicates there’s something consistent happening. In both cases, it was the NON-default account that wouldn’t  show up. I don’t know if that helps to know. All the standard folders are behaving fine. It’s just the smart folders where the non default accounts have vanished from twice now.

Hi Chris, what version of eM Client are you currently using on your computer? Does this still occur from time to time now in your client?
Are you able to possibly make a screenshot of the issue, what smart folders are you having issues with? Do you have only two accounts added in your client?

There should be no difference between which account is set as default and all your email (based on the smart folder) should be displayed in the folders.

Thank you,
Paul.

I am still using the same version as when I first posted the issue. It’s only happened twice so far so even if I wanted to I couldn’t offer a screen shot since it’s not currently happening. To be honest, for privacy reasons I wouldn’t do that anyway. I would have to blur out the visible text, which in turn would defeat the purpose of taking a screen shot.

It’s not hard to imagine what happened though. I have two accounts set up.

Mail A is gmail default.

Mail B is exchange account.

Right after updating to the version mentioned in my first post, Mail B would not display in smart folder. Only Mail A would.

Restarting EM Client, both accounts showed up in smart folder.

Later, I switched default account to Mail B, restarted EM client, then Mail A would not display in smart folder.

Restarting EM again, both accounts showed up in smart folder.

I have returned Mail A to default status and have not yet seen either accounts failing to display in smart folders since.

That’s it. That’s all I can tell you. I haven’t  had time to play around with the settings since then, but if it does happen again, of course I will return here and let you know.

Hi again, I tried to replicate the issue, but unfortunately I was not successful, you can try to update to this version http://www.emclient.com/dist/v6.0.20968/setup.msi , and let me know if the issue reoccurs.
I understand screenshots may contain some private information, in that case you can send it to my email (mcgregor@emclient.com).

Can you also please comment on which smart folders did you have the issue with?

Thank you,
Paul.

No issues after this morning’s update to version 6.0.21015.0 so I would consider this resolved at this point.

Hi Chris, I’m glad it works, but please make sure to update to this release http://www.emclient.com/dist/v6.0.21034/setup.msi as it contains several more bug fixes regarding the issue you were having.
Please let us know if you come across any other issues or questions, we’ll be happy to help.

Thank you,
Paul.

Already do’d it. Thanks!