Exchange 2007 Mac v8

Can’t get exchange 2007 account to work in v8. Account adds but never syncs, error log below. Any ideas? UI just says connection failed in yellow triangle.

Exception: MailClient.Accounts.ConnectionException: An error occurred while sending the request —> System.Net.WebException: An error occurred while sending the request —> System.Net.Http.HttpRequestException: An error occurred while sending the request —> System.Net.WebException: Error: SecureChannelFailure (Authentication failed, see inner exception.) —> System.Security.Authentication.AuthenticationException: Authentication failed, see inner exception. —> Mono.Security.Interface.TlsException: Unknown Secure Transport error `Negotiation’.
at Mono.AppleTls.AppleTlsContext.CheckStatusAndThrow (Mono.AppleTls.SslStatus status, Mono.AppleTls.SslStatus[] acceptable) [0x000dc] in <079e0be24b7147ccaf9d0444926d8e4d>:0
at Mono.AppleTls.AppleTlsContext.ProcessHandshake () [0x0002e] in <079e0be24b7147ccaf9d0444926d8e4d>:0
at Mono.Net.Security.MobileAuthenticatedStream.ProcessHandshake (Mono.Net.Security.AsyncOperationStatus status, System.Boolean renegotiate) [0x000da] in <079e0be24b7147ccaf9d0444926d8e4d>:0
at (wrapper remoting-invoke-with-check) Mono.Net.Security.MobileAuthenticatedStream.ProcessHandshake(Mono.Net.Security.AsyncOperationStatus,bool)
at Mono.Net.Security.AsyncHandshakeRequest.Run (Mono.Net.Security.AsyncOperationStatus status) [0x00006] in <079e0be24b7147ccaf9d0444926d8e4d>:0
at Mono.Net.Security.AsyncProtocolRequest.ProcessOperation (System.Threading.CancellationToken cancellationToken) [0x000fc] in <079e0be24b7147ccaf9d0444926d8e4d>:0