EWS subfolders

Hello, I’m trying em client with SmarterMail 12 by EWS. The setup was easy and fast. The problem: I have a hugh subfolders tree and all of these folders are shown only in 1 level (without the tree). Must I setup something? Here you have the same account in Thunderbird and emClient

EmClient folder tree:
https://www.dropbox.com/s/bi2pugi03v278x7/WrongFolderTreeEmClient.png

Thunderbird folder tree:
https://www.dropbox.com/s/bdi1x2br51d5oy8/Right%20folders%20tree%20in%20Thunderbird.png

Hi, are you using this server with an Exchange email?
If so can you please go to Tools > Settings > Advanced and turn on Exchange Web Services logging for the problematic account?
Save the settings and restart the application then you can maybe try right clicking your email folder in the left sidebar and select Properties > Repair, and click on the Repair button.

After you do this go back to the advanced settings window and click on “Send Logs”, please send it to my email instead of the default one (mcgregor@emclient.com).

If you’re not using Exchange, turn on IMAP logging instead of Exchange Web Services.

Thank you,
Paul.

How to view global address book using EWS with eM client while connecting to SmarterMail 12.x server?

Hi again,
unfortunately it’s not possible to access global address book in eM client at the moment, but it’s planned for future releases.
Global address contacts should be displayed in the auto complete feature if you’re typing an address into the to/cc/bcc field in a new message window.
However in order to view them all or edit the contacts you have to access the webmail or the smartermail service, you’re using.

Thank you for understanding,
Paul.

Hi,

The problem is not the address book. The problem is about the lost hierarchy in IMAP FOLDERS. Using IMAP protocol, the folders are shown OK. Using EWS the hierarchy is lost. Using IMAP, I can’t syncronize contacts, calendar an tasks. Using EWS, I can have a whole syncronization but I have many folders with the same names at the same level. Each of this folders are in the backups of several years, and only one is current. But with the hierarchy lost, I don’t have possibilities to know which one is the current folder.

Thank you

Hi Omar, I was answering someone else’s question, as to the original issue, did you do the repair on your account and turned on Exchange Web Services logging, I don’t see any logs received in my email from you, can you please send me these files in order to resolve this issue?

Thank you,
Paul.

The log is too big.
This is the reason I sent it usign a link to dropbox

https://www.dropbox.com/s/uwe3hnnbmt1ko91/2014-05-03_09-17-47%20omar.escalante%40frimont.com%20Exchange%20Web%20Services.log

I will resend the email now.
Thank you

Thank you, I’ll forward the logs to the developers for further examination, please be patient, hopefully I’ll be able to get back to you with a solution.

Thank you for understanding,
Paul.

Great