Event is moved after modification (timezone difference from server to client?)


I’ve just installed eM Client (7.1.31849.0) on my Windows client to use exclusively to access calendars in a CalDAV server (replacing Thunderbird+Lightning), and it’s looking to be way better right off the bat. 

However, I have noticed there’s an issue (bug?) that didn’t happen with Thunderbird (or any other CalDAV clients) that is really troublesome.

Basically, I can create an event just fine, and that will sync fine as well across devices. However, if I modify the event  with eM Client (any field really, I’ve tested title, start, end, etc), the start time of the event will change after synchronisation with the server, being moved 5 hours laters in time. Any subsequent change will compound to the previous start time. This does not happen when modifying an event with any other client.

For reference, the server is located in Toronto, Canada, and the client is located in Lisbon, Portugal (5 hour difference). Timezone is set to automatic on Windows, although I also tried with that disabled.

I.e. I create an event at 10:00, it’s fine on all devices. If I change its title and save (the event window shows 10:00 before saving), after sync the event will now start at 15:00. If I change the title once again, it will now start at 20:00 - and so on. 

I tried finding some info about this on the forum, but found nothing similar. Can anyone help with this?

Although other clients didn’t need this, but this is solved by setting the correct timezone, per user, in the CalDAV server. In my case, using Horde via cPanel to change these settings per user.

Glad you found a solution. I assume this is not something the user can change themselves.

If you have a Pro License, can you create a ticket for this so that the developers can look into it? I had some issues with GMX CalDAV and time zones, and after reporting it to support, it has now been corrected for the next release.

It actually is. I had to change the default timezone setting for my user (in this case, only possible using Horde, I guess), under General Preferences. 

(oh, and I don’t have a Pro license, sorry)