Errors when connecting to Outlook (formerly Hotmail)

After my hotmail account transferred to the new new Outlook service, my account stopped working. 
I removed it and readded it and then it still didnt work. I then changed the server address from m.hotmail.com to m.outlook.com and that seemed to do the trick (in as much as it synced my folders and I can send email). 

However I still get many errors popping up. They are very annoying and I am also left concerned that the changes (deletions, moving mails to folders etc) may not always by sync’d properly).

The errors are:
“Error in client/server conversion”
“Specified method is not supported”

Any help much appreciated!

Same problem here, using version 6.0.24928.0. Not sure why but two of my outlook accounts are working, the third one gives me the error message: MailExceptions.OperationException: Error in client/server conversion.

If your hotmail account has been migrated to the new Microsoft Exchanger server you need to set it up using Exchange in eM Client

To find out if Microsoft has migrated your account yet - in a Browser, login to your account at outlook.com. When your mailbox has been migrated to the new infrastructure, the top left corner will show Outlook Mail. When your account hasn’t been migrated yet, it will show Outlook.com.

If it shows Outlook Mail , you need to set up your account in EM client as an Exchange account. iMAP will still work, but not as well as Exchange (also Calendar and Contacts are not synced with iMAP).  An EM Client  Outlook account (ie using AirSync)will no longer work. 

Note that when you set up an Exchange account, EM Client can take quite a few minutes to obtain the server details.

See this relevant doco

https://drive.google.com/open?id=0B8ey_8poDxPUQV85WmU3bjNobVk

Thanks very much for the response. I have done this (having confirmed I am on the new system) but I still get errors as below. Any ideas? 
Thanks

“Synchronizing folder ‘email@hotmail.com/Contacts.’ failed due to the following error: Invalid data source operation., There was a problem accessing Active Directory. Check your network connections and try again.”
and

“Error in client server conversion”

Are you using the latest version of eM Client - 7.0.26687.0?

Have you tried deleting the account in eM Client and setting it up again?

I am using 6.0.24928. When I click update, it says none available.

I have already deleted my account and re-added - no change.

The only things I can suggest are:
Try version 7
See if there is a problem at the Microsoft end