Error Received after install: Sending email failed due to the following error: A time zone with the specified ID could not be found.

Trying to connect to Exchange 2007 version 8.3.389.2. We have OWA enabled.

Hi Peter,
could you replicate the error and when you do, click the next tab in the same window as the error (Log) and copy it’s contents here.

Regards,
Olivia

8:37:47 AM Online state: changed to online due to NetworkAvailability

8:37:47 AM ptetrault@wellesleypartners.com[Offline Address Book]  Synchronizing folder list

8:37:48 AM ptetrault@wellesleypartners.com[Offline Address Book]  Synchronizing folder list

8:37:48 AM ptetrault@wellesleypartners.com[Offline Address Book]  Synchronizing folder ‘ptetrault@wellesleypartners.com/Global Address List/’

8:37:48 AM ptetrault@wellesleypartners.com[Exchange Web Services]  Synchronizing folder list

8:37:50 AM ptetrault@wellesleypartners.com[Exchange Web Services]  Synchronizing folder list

8:37:53 AM ptetrault@wellesleypartners.com[Exchange Web Services]  Sending email

8:37:53 AM ptetrault@wellesleypartners.com[Exchange Web Services]  Sending email: test

8:37:53 AM   MailExceptions.OperationException: Sending email failed due to the following error: A time zone with the specified ID could not be found. —> Microsoft.Exchange.WebServices.Data.ServiceResponseException: A time zone with the specified ID could not be found.

8:37:53 AM    at Microsoft.Exchange.WebServices.Data.ServiceRequestBase.ProcessWebException(WebException webException)

8:37:53 AM    at Microsoft.Exchange.WebServices.Data.ServiceRequestBase.GetEwsHttpWebResponse(IEwsHttpWebRequest request)

8:37:53 AM    at Microsoft.Exchange.WebServices.Data.ServiceRequestBase.ValidateAndEmitRequest(IEwsHttpWebRequest& request)

8:37:53 AM    at Microsoft.Exchange.WebServices.Data.MultiResponseServiceRequest`1.Execute()

8:37:53 AM    at Microsoft.Exchange.WebServices.Data.ExchangeService.InternalCreateItems(IEnumerable1 items, FolderId parentFolderId, Nullable1 messageDisposition, Nullable`1 sendInvitationsMode, ServiceErrorHandling errorHandling)

8:37:53 AM    at Microsoft.Exchange.WebServices.Data.Item.InternalCreate(FolderId parentFolderId, Nullable1 messageDisposition, Nullable1 sendInvitationsMode)

8:37:53 AM    at Microsoft.Exchange.WebServices.Data.EmailMessage.InternalSend(FolderId parentFolderId, MessageDisposition messageDisposition)

8:37:53 AM    at MailClient.Protocols.Exchange.ExchangeMailSynchronizer.<>c__DisplayClass13.b__12(WorkerStatus
status, CancellationToken cancellationToken)

8:37:53 AM    at MailClient.Protocols.Exchange.ExchangeGenericCommand.Execute(WorkerStatus status)

8:37:53 AM    — End of inner exception stack trace —

8:37:53 AM    at MailClient.Protocols.Exchange.ExchangeGenericCommand.Execute(WorkerStatus status)

8:37:53 AM    at MailClient.Commands.Command.Process(WorkerStatus status)

8:37:53 AM ptetrault@wellesleypartners.com[Exchange Web Services]  Synchronizing folder list

8:37:53 AM ptetrault@wellesleypartners.com[Offline Address Book]  Synchronizing folder list

8:37:53 AM ptetrault@wellesleypartners.com[Offline Address Book]  Synchronizing folder ‘ptetrault@wellesleypartners.com/Global Address List/’

Hi Peter,
sorry for the late reply, but it seems we’ll need more information about this issue.
Can you go to Tools>Settings>Advanced and turn Exchange Web Services logging for this account?
Restart eM Client and then when this error appears again, go to Advanced settings, click ‘Send logs’ but change the recipient of the message to me (rust@emclient.com) and add a link to this forum topic to it so I can get back to you here on the forum.

Regards,
Olivia