error opening attachments

A problem has arisen whereby if I double/right click any attachment (any file type) & then click on “open” in the dialogue box, I get an error message “error occurred when saving the attachment: could not find part of the path C:…” I have gone into windows (8) explorer to trace the file path and the issue seems to be the (strangely worded) subfolder under “eM Client Temporary Files” does not exist. moreover each time I try to open the same attachment this subfolder has a different name. no problems with “save as” in the dialogue box, just opening the attachment from eM Client. could the issue have arisen after a recent windows 8 update…???

Hi, can you please make a screenshot of this error/issue and post it here?
What version of eM client are you currently using?

Thank you,

hi Paul…

version 6.0.20154.0 (current version)

how do I do a screen shot?



If you’re using Windows 7 or 8 , there’s an application in your computer called “snipping tool”, if you’re using earlier version just use the print screen button on your keyboard and go to paint and press ctrl + v and save the image onto your computer.


I have highlighted the folder that doesn’t seem to exist anywhere and changes each time I try to open an attachment (same or different).

This is the box that appears when I try to open .doc attachement - will “save” ok, but not “open”. if I try to open other file type eg .pdf this box does not appear - just comes up with error message.

Hi again, can you please check if you have permissions for creating folders in the eM Client temporary files folder?

Thank you,

this worked!

for anyone else reading this thread, you need to right click on the “eM Client temporary files” folder icon, select “properties” -> go to “security” tab, then select “users” and click “edit” button and make sure “write” box is ticked (as per screen shot above).

thanks for your help Paul

Great! I’m glad it works now, and thank you for sharing more detailed instructions.
Let me know if you come across any other issues or if you have any questions about the application!

Thank you,

this issue seems to have arisen again.  I have checked the above process and all seems to be in order ie. ticks where they should be etc. the folder “C:\Users\Fredric\AppData\Local\Temp\eM Client temporary files” is a read only folder, however when I deselect this property -> apply -> give admin approvals etc. it simply changes it back to read only when I try to open an attachment again from within eMclient.  any thoughts??

This is a big problem for us. When receiving an invoice we sign the PDF with a note and forward it to the right person. Because it is read only we first have to save the attachement in a different folder, close the PDF, open the PDF from the new folder, make the note, save it again, back to the mail, forward it, IMPORTANT - delete the original attachement, attache the new PDF and send the mail.

It you do that once a week no problem, if you do that many times every day it is not good. We discovered today this problem because we decided to switch to eM client. I am not so sure the descission would be the same if we knew about this problem.

If you open a mail and forward that, the changes to the attachment in the forwarded mail has to be done directly in the attachment.

Hello, what mail service are you using with eM Client? Are you using an Exchange account? What version of eM Client are you currently using on your computer, can you please check the exact release number in Help > About? Or try to update your eM Client to this release, 6.0.22504.0 and check if the issue persists?

If you’re using an Exchange account, try to perform a folder repair on all affected folders, if you’re unable to download an attachment in a selected folder, right click the folder and select Properties > Repair and perform folder repair using the “Repair” button. This will essentially resynchronise the folder with the server hopefully re-allowing attachment download.


We have installed 6.0.22344.0. I tryed to update to 6.0.22504.0 it did did not solve the problem. We are using Google as mail provider. The attached file is with 6.0.22504.0 still read only when opening.

As I can se the problem is that the “eM Client temporary files” and all subfolders/files are created as read only and you can not change that. I can change it, but when closing eM client the temporary folder is removed. Next time we start the client and opening an attachment the folder is recreated, but again with every thing as read only.

Hello Gert, I’m afraid this might be caused by running eM Client without administrator permission, try to run the application as an administrator and check if the issue persists.