Error message when syncing with google contacts (My Contacts)

I categorized all of my contacts as “my contacts” so that they would carry through to google and then to my iPhone. I recieved the attached error message.

it has been already fixed in our internal version and it will be implemented in the next major version. Meanwhile you can open your account settings, tab Calendar and Contacts, choose “Use these credentials” and fill in the full email address and password. It should help.

Thank you. This seemed to have resolved the issue.