Error message in diagnostics "object not found in database"

I am getting a red triangle against my main account icon saying “Connection Failed” this does not seem to be stopping my email, calendar and contacts have some problems staying in sync acrosss my laptop / phone and server.

I have tried deleting all emails in junk and spam folders on the server copy then resyncing. No change.
I have tried deleting my account out of emclient and recreating. No change
I have deleted a lot of archived calendar entries. No change
I have removed any antivirus filtering (bitdefender) No change.

My email server is hosted with AWS workmail. Here is the only error message in the diagnostic logs I could find.

6:22:06.630|049|   </Trace>
16:22:06.631|049|   <Trace Tag="EwsResponse" Tid="73" Time="2023-01-23 16:22:06Z" Version="9.2.1222.0">
16:22:06.632|049|     <?xml version="1.0" encoding="utf-8"?>
16:22:06.633|049|     <soap:Envelope xmlns:soap="" xmlns:xsi="" xmlns:xsd="">
16:22:06.634|049|       <Header xmlns="">
16:22:06.635|049|         <ServerVersionInfo MajorVersion="14" MinorVersion="2" MajorBuildNumber="390" MinorBuildNumber="3" Version="Exchange2010_SP2" xmlns="" />
16:22:06.635|049|       </Header>
16:22:06.636|049|       <soap:Body>
16:22:06.637|049|         <m:GetUserConfigurationResponse xmlns:t="" xmlns:m="">
16:22:06.638|049|           <m:ResponseMessages>
16:22:06.639|049|             <m:GetUserConfigurationResponseMessage ResponseClass="Error">
16:22:06.640|049|               <m:MessageText>The specified object was not found in the store.</m:MessageText>
16:22:06.641|049|               <m:ResponseCode>ErrorItemNotFound</m:ResponseCode>
16:22:06.641|049|               <m:DescriptiveLinkKey>0</m:DescriptiveLinkKey>
16:22:06.642|049|             </m:GetUserConfigurationResponseMessage>
16:22:06.643|049|           </m:ResponseMessages>
16:22:06.644|049|         </m:GetUserConfigurationResponse>
16:22:06.644|049|       </soap:Body>
16:22:06.645|049|     </soap:Envelope>
16:22:06.645|049|   </Trace>
16:22:06.646|049|   <Trace Tag="EwsRequestHttpHeaders" Tid="73" Time="2023-01-23 16:22:06Z">
16:22:06.647|049|   POST /EWS/Exchange.asmx HTTP/1.1
Accept-Encoding: gzip,deflate

Thanks for any assistance you can offer.