Error 10060

I’ve been using eMclient for a while now. Initially installed on Windows 8.1 64 bit then upgraded to Win 10 64 bit. Since the last Update ??? I’ve been getting an error 10060 when fectching my mail once in a while. Now in the last 3–4 days it’s nearly all the time. I’ve run diagnostics and it fixes(?) the problem, but no joy. Here is the latest error log -

11:04:05 AM Online state: changed to online due to NetworkAvailability
11:04:05 AM [email protected] [POP3] Connecting: To [email protected]
11:04:26 AM MailExceptions.Exception: Invalid first reply: -ERR Cannot connect to POP server 2001:558:fe16:1b::13 (2001:558:fe16:1b::13:110), connect error 10060
11:04:26 AM at MailClient.Pop3.Pop3ReceiveCommand.Connect(WorkerStatus status)
11:04:26 AM at MailClient.Pop3.Pop3ReceiveCommand.Execute(WorkerStatus status)
11:04:26 AM at MailClient.Commands.Command.Process(WorkerStatus status

Thanx for any help,


Tried a number of things including a number of reboots. No Joy. I turned off my Firewall and Anti-virus software and that solved the problem. When I reinitialized the software the problem did not reappear. it’s been 3 hours since it started working again. Hurrayyyyy!!!

Hi Dennis,

Yes, as I was about to suggest, these problems often stem from a firewall or an antivirus - just add an exception for us and you should be golden.

Glad you solved the issue.


I spoke too soon (maybe). If I turn off the Firewall I have no problems from 30 minutes to 4 hours. I know it’s the Fire Wall because if I turn it off temporarily, everything is fine for a while. Then it comes back. I’ve put in exceptions using my email address, smtp server and pop3 server. I’ve never used exceptions before, so my question is if these entries are incorrect., how do I type in the correct exception?

Hello Dennis,
what David meant is adding an exception in your Firewall for eM Client, not for your address and server.


If I understand you correctly, I’m to put the Path of eMClient in the exception list? Thanx will try that.

Still getting the same error. All is good when I disable the Fire Wall. Below is error log.

8:06:09 PM MailExceptions.Exception: Invalid first reply: -ERR Cannot connect to POP server 2001:558:fe16:1b::13 (2001:558:fe16:1b::13:110), connect error 10060
8:06:09 PM at MailClient.Pop3.Pop3ReceiveCommand.Connect(WorkerStatus status)
8:06:09 PM at MailClient.Pop3.Pop3ReceiveCommand.Execute(WorkerStatus status)
8:06:09 PM at MailClient.Commands.Command.Process(WorkerStatus status)
8:35:47 PM [email protected] [POP3] Connecting: To [email protected]
8:36:09 PM MailExceptions.Exception: Invalid first reply: -ERR Cannot connect to POP server 2001:558:fe16:1b::13 (2001:558:fe16:1b::13:110), connect error 10060
8:36:09 PM at MailClient.Pop3.Pop3ReceiveCommand.Connect(WorkerStatus status)
8:36:09 PM at MailClient.Pop3.Pop3ReceiveCommand.Execute(WorkerStatus status)
8:36:09 PM at MailClient.Commands.Command.Process(WorkerStatus status)
9:05:47 PM [email protected] [POP3] Connecting: To [email protected]
9:06:09 PM MailExceptions.Exception: Invalid first reply: -ERR Cannot connect to POP server 2001:558:fe16:1b::13 (2001:558:fe16:1b::13:110), connect error 10060
9:06:09 PM at MailClient.Pop3.Pop3ReceiveCommand.Connect(WorkerStatus status)
9:06:09 PM at MailClient.Pop3.Pop3ReceiveCommand.Execute(WorkerStatus status)
9:06:09 PM at MailClient.Commands.Command.Process(WorkerStatus status)
9:35:47 PM [email protected] [POP3] Connecting: To [email protected]
9:36:09 PM MailExceptions.Exception: Invalid first reply: -ERR Cannot connect to POP server 2001:558:fe16:1b::13 (2001:558:fe16:1b::13:110), connect error 10060
9:36:09 PM at MailClient.Pop3.Pop3ReceiveCommand.Connect(WorkerStatus status)
9:36:09 PM at MailClient.Pop3.Pop3ReceiveCommand.Execute(WorkerStatus status)
9:36:09 PM at MailClient.Commands.Command.Process(WorkerStatus status)
10:05:47 PM [email protected] [POP3] Connecting: To [email protected]
10:06:08 PM MailExceptions.Exception: Invalid first reply: -ERR Cannot connect to POP server 2001:558:fe16:1b::13 (2001:558:fe16:1b::13:110), connect error 10060
10:06:08 PM at MailClient.Pop3.Pop3ReceiveCommand.Connect(WorkerStatus status)
10:06:08 PM at MailClient.Pop3.Pop3ReceiveCommand.Execute(WorkerStatus status)
10:06:08 PM at MailClient.Commands.Command.Process(WorkerStatus status)
10:08:38 PM [email protected] [POP3] Connecting: To [email protected]
10:08:39 PM [email protected] [POP3] Connected: To [email protected]
10:08:39 PM [email protected] [POP3] Downloading messages: From [email protected]
10:08:42 PM [email protected] [POP3] Disconnected: From [email protected]
10:08:42 PM [email protected] [POP3] Disconnected: Done
10:11:12 PM [email protected] [POP3] Connecting: To [email protected]
10:11:12 PM [email protected] [POP3] Connected: To [email protected]
10:11:12 PM [email protected] [POP3] Downloading messages: From [email protected]
10:11:13 PM [email protected] [POP3] Disconnected: From [email protected]
10:11:13 PM [email protected] [POP3] Disconnected: Done
10:11:21 PM [email protected] [POP3] Connecting: To [email protected]
10:11:22 PM [email protected] [POP3] Connected: To [email protected]
10:11:22 PM [email protected] [POP3] Downloading messages: From [email protected]
10:11:22 PM [email protected] [POP3] Disconnected: From [email protected]

Hello Dennis,
if turning off the firewall stops this issue, then the exception must not be set correctly.
I suggest reading through this article and following the steps mentioned -… (according to a post from Windows support these instructions apply to Windows 10 as well).


Read the Exception , actually the Fire wall article and followed the directions in the article. When I did that Windows would not allow me too put the exception in because it was already there. I deleted the older exception and re-applied the exception. Still no good. Maybe I should uninstall Em Client and clean my registry then do a reinstall and import my data and contact lists? What do you think?

Hello Dennis,
this is really peculiar, especially since turning the firewall off works, but the exception doesn’t. Maybe try excluding your database folder from the Windows defender as well. (database folder location can be found in Tools>Settings>Storage)
You can try the reinstall and registry cleanup, but I do not think it will change much. Just make a backup of your database just in case (File>Backup) and you won’t have to worry about your data and settings. It should not even be needed, as uninstalling eM client won’t erase your database, but it’s always better to be on the safe side.


First of all thanx for all your help. As for the data base, Windows will not allow anything but an executable file to be entered into it. Unless there is another way of directly accessing and editing the exclusion database , I don’see anyway around this problem. What amazes me is that when I turn of the firewall off and then reactivate it, the problem is solved for a time up to as much as 3 hours, Also it seems on start-up the problem does not occur for a time. Thanx again— Dennis

Dear Olivia,
I removed Em Client and cleaned my registry of any instance or direction of Em client. Then reinstalled. That seemed to solve the problem for nearly the whole day following. Then the problem reappeared. I then checked for updates and installed them to update Em client. Then when I restarted it seemed to work fine for a while. Then good ol 10060 came back sporadically. Em Client seems to work initially every morning when I do an initial startup of the system and when I shutdown Em client and restart it during the day. One other thing I neglected to tell you is that i have Avast Internet Security installed. It appears Avast uses the Windows fire wall with their own overlay. I’ve put exceptions in the Avast front end and it appears in Windows fire wall as well. That is why I believe it is only an overlay. I may be wrong, but it definitely works in conjunction with windows fire wall. Any Ideas?
Thanx again

As it turns out my Avast Internet Security has been causing all my 10060 error problems. I have removed this program and haven’t had a problem since (5 Days). I tried to contacting Avast and as yet gotten any response.
Thanx for your assistance in the past and as usual it’s not a problem with your program, it is another program interfering with EMClient of doing it’s job.
Thanx for everything.

Hello Dennis,
sorry for the delayed reply on your previous reply, but I am glad to hear you found the root of the issue :slight_smile:
Thank you for sharing the real reason on the forums in case anyone else encounters the same problem with avast.


I’ve been in touch with Avast and they say it’s possible that I got corrupted files during an update is the actual cause. I have reinstalled using an updated installer. I’ll give it a couple of days and report back whether or not this is a true fix.

It seems the Avast tech was on the money. My system has been up for about 60 hours and not one error of any kind. I feel the 10060 error code is in the past. Thank you Olivia for your time and recommendations. You guys put me on the right track to rectify the problem. I’m glad it wasn’t your product as I really like your e-mail client.
Again my thanks

Hi Dennis,
thank you for getting back to us and clarifying your problem and the solution.
Glad to hear everything is working now :slight_smile:

Best wishes,