Encrypted subjects

Hello, I use the Russian language in messages and I have a problem with some letters. Message in the subject the UTF-8 is not displayed correctly. When the receiver gets a letter, its subjects topic looks as a coded text, lke this:

Other client

How can I solve this problem?

One email with problem in eml format

Thanks in advance.

There were a few posts specifically about Russian language encoding in subjects. Unfortunately there has not been a solution so far.

Please see
https://forum.emclient.com/emclient/topics/utf-8-subject-encoding
https://forum.emclient.com/emclient/topics/encoding-message-subjects-in-utf-8

There have also been some with other languages also, but as far as I remember, there was no resolution.

Hi Sergey,

I tried to reproduce the issue but I receive the emails with Russian subject correctly displayed at my end. Could you please send me such email to markosky@emclient.com so I can test the issue?
Thank you.

Russel

There was a question about the sender’s name displaying incorrectly, and Olivia commented that it was because of a server issue. Could this not be the same?

Hi Russel! I changed the server settings, now everything is ok, but in other email clients everything worked without changing the server settings.

Old subject:
Subject: ??? ???U5L6I - ??? ???
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

New subject:
Subject: =?UTF-8?B?0J3QvtCy0YvQuSDQt9Cw0LrQsNC3IEMxSTEy?=
Content-Type: text/html; charset=UTF-8
Content-Transfer-Encoding: 8bit

If need test, I can change the server settings to back

I guessed it is a server-related problem but I wanted to make sure.

Thank you Sergey for the information, it confirmed my guess. I’m glad the issue was resolved.

Russel

Hi, I have a similar problem, but I use charset=windows-1251. Other email clients display subject correctly

It seems eM Client is not as forgiving as other email clients when servers are not correctly configured. 

Which mail server are you using?

IBM Domino Release 9.0
All email clients display subject correctly (Mozilla Thunderbird, Outlook).
If i save message to eml-file and open it in eM Client, then subject has a different view:

original message (in ANSI - WIN 1251 coding):

MIME-Version: 1.0 Received: from mail.orenpay.ru ([192.168.126.31]) by mx-notes.orenpay.ru (IBM Domino Release 9.0) with SMTP id 2018080211441973-183975 ; Thu, 2 Aug 2018 11:44:19 +0500 From: cn@orenpay.ru To: a.alymov@orenpay.ru Subject: Тестовое сообщение Date: Thu, 2 Aug 2018 11:44:19 +0500 Message-ID: <of5cda8207.8d42f9c5-on452582dd.00250475>
Content-Type: text/plain; charset="windows-1251"
X-MIMETrack: Itemize by SMTP Server on MX-NOTES/GOROD(Release 9.0|March 08, 2013) at
 02.08.2018 11:44:19

Тестовое сообщение</of5cda8207.8d42f9c5-on452582dd.00250475>

Maybe Russel will comment. If he does not, and you have a Pro License, it might be better for you to open a support ticket.

Hi Anatolij,

Send me please such .eml to my email address markosky@emclient.com.

Thank you,
Russel