enable non-html hyperlink in messages - M-Files links mflink:{GUID} recognized, but disabled

M-files (a document management system) sends document references as URL “m-files:{document-GUID}”. The links show in blue, but they cannot be clicked through, even though the link type is registered in Windows and Outlook and other apps recognize it.

Below the “Web” link is a usual html link to the cloud M-Files; others are “m-files” types recognized by the M-Files client on local PC. Only “Web” is clickable. 

 

The link is there in the body of the message, but eM Client blocks it. 

A4B6BE4A5D/0-36448?object=3D40EB62BE-5A90-4275-BAF6-6B8036E7F6A1">10_2020_A=
genda

I understand that for security reasons eM Client does not enable unusual links. This is probably one of them.

Thanks, this is basically a local file link to a VFS registered on a local PC. It really should not be an issue; I think this is just a makeshift safety device that could be user controlled, or should not be there at all in a production version (using 8 Beta, but 7 was the same). 

Do you know how to make this into a “feature request” ticket?

Create a new thread on this forum, but instead of making it a Question or Problem, make it an Idea. The concept is that other users can vote on it, and those that show enough interest might be considered.

But as the issue is there with the beta, you could send an email to testing@emclient.com. They might give some reply to your feedback.