eMClient v6.0.22283.0 and Google

I updated to 6.0.22283.0 last night.  When I tried to access my email, I was presented with a screen to log into each of my Gmail accounts.  Then I got a screen requiring me to accept “authorization” for Google to do whatever it does.  I’m sure that whatever I agreed to will allow Google to invade my privacy even more, but I could NOT access my email without this authorization.  What is this “new” relationship between eMClient and Google, that suddenly appeared with 6.0.22283.0??

Oh ffs.

If you actually READ what it was asking before, you wouldn’t look like an idiot.

It asks for:

“View and manage your email”. What do you think an EMAIL client actually does?

“Know who you are on Google” It wants to know your G+ profile. Who the hell cares, no one uses it?

“Manage your calenders” This is the nifty feature that the CALENDER section of the client uses.

“Manage your contacts” You know how you can email a contact?

“View and send chat messages” This is the nifty feature that the CHAT section of the client uses.

“Manage your tasks” This is the nifty feature that the AGENDA section of the client uses.

So next time before you don’t read anything and make a shitpost, try again.

Thank you for such a “helpful” comment.  I guess your morning must be worse than mine.

Not a problem. And nope, it’s actually going pretty good. Thanks for asking.

There could be some debate on who came across as an “idiot”. You can be helpful without  being a "smart-ass’.

Connie B,
I had the exact same problem and I, like you, am not happy about it. Is there anyone out there who can give us an explanation for the change without being rude?
It’s very annoying because everytime I open eMclient Google asks for my password.
What happened to being able to store your password with eMclient and automatically have access to your email? The only time I was asked for my password is if I had changed it.  I am not at all happy with the new way of doing things. Google is invasive enough.

Hello, Google has changed it’s authentication option, it is no longer possible to authenticate with your mail server using the regular password as you were used to, instead Google has adopted a new technology called OAuth, which calls a browser window and authenticates with your account using a special token sent to eM Client through this authentication window. This token is then stored within the application’s settings and used for authenticating with your mail server. It’s actually a much safer method to allow access and share data with 3rd party applications as eM Client is.

Hope this helps.

Shame on you. It is quite obvious that em client works wrong with Google OAuth2. After user has computer restarted em client should not ask to login each time. The reason is that your developers do not store google authorization token. Please prepare an update as soon as possible because it totally impossible to use your application anymore.

Hello Alex, certainly this is not the case, I’m having no issues with my current setup as the application is able to store my password without problems, try to udpate your eM Client to this release and check if the issue persists after update, http://www.emclient.com/dist/v6.0.22298/setup.msi .

Unfortunately, it is not possible, because my current version is 6.0.22313.0. Em client does not allow to do downgrade. 

So, it could be the case.

If the issue persists, and you’d like to help us resolve it, please download this utility, http://www.telerik.com/fiddler and run the logging, before you start capturing traffic, please go to Tools > Fiddler Options > HTTPs > Decrypt HTTPs. 

Enable capturing trafic and try to replicate the issue when eM Client re-promtps you for password, restart the computer, start fiddler and open eM Client, if the password required option pops up, submit the fiddler archive that includes the logging data to my email, mcgregor@emclient.com with a reference link to this forum topic.

Hello, I am presented with the same gmail authentication and enter my password, then confirm it with google PIN for an authentication number and all is well… But, then, if my laptop goes to sleep, is powered off or hibernates and the next time I try to use emclient, I am presented with the whole logon scenario again, (enter password, google authentication pin, etc…) has happened three times already… Can this be fixed?

Thanks Paul. That does help explain what’s going on and why.

I installed the update that was available today for emClient, and the repeat google login prompt has gone away.

Paul, Irv, thank you for your help. I have installed a last update (6.0.22328.0) and the problem has gone away.

Hi, well, my problem came back…

I’ve the same problem too. when I set my email address and password a wide window open: then nothing happend.
I just try to download a new release, but I have last version. I tried with fiddler … nothing.

Any ideas?
 
Thank you

Hello, please make sure you’re running the latest release, http://www.emclient.com/dist/v6.0.22336/setup.msi , this update should hopefully resolve a case when regaining access to internet connection when the token has timed out.

Let me know if the issue persists.

Ok, I did not have this version even though I checked for updates this morning. I’ve install version 6.0.22336, I’ll report back if I get the google logon prompt.

Thanks!