emClient does not provide MyCalendar

To whom it may concern!

Just recently, my emClient (8.2.1473 (04b618f)) seems to have lost MyCalendar – it only provides the Local Calendar.
Synchronizing with my internet calendar (GMX / CalDAV) and my Android calendar (therefore) is not possible.
Re-setting the IMAP-account has not solved the issue.

Looking forward to helpful support!

KR, Bernd

I would suggest then as you have already removed and re-added your IMAP account and the Calendar on the server online appears ok, Sounds like then either a problem with database itself somewhere, or eM Client program itself.

If you have recently make a backup of eM Client (when the calendar was working), try restoring via “Menu / File / Restore” using the Windows version to see if that fixes it. Before restoring make a backup via “Menu / Backup”.

If you have no backup or restoring made no difference to the problem, then try uninstalling eM Client and “don’t delete the database on uninstall”. Then d/l the same version from the ver history page and reinstall. eM Client will pickup your exiting database and hopefully the calendar will start working if it was program related. https://www.emclient.com/release-history

Thanks for your response.
I shall give it try … and let community know about the result!

Now I did try to follow your advice.

Since I had no backup to solve the problem I uninstalled eM Client without deleting the database. Re-installing the same version did not succeed since for whatever reason my database had been re-configured by a later version. Moreover, the installer interrupted for adding a more recent version than I was about to install.

In any case, the calendar still does not provide the “MyCalendar” folder.

Therefore, I am at a loss currently.

I use GMX.com for my personal email, and I have access to my calendar.

Go to Menu > Accounts and remove the GMX account from eM Client. Then add it back again using the Automatic Setup.

This will add messages, contacts and calendars.

I shall give it a try right away; using GMX myselg, by the way.
Shall keep you posted.

Ah ok. I had thought you had (already removed your IMAP account) as per your initial post at the top Quote - "Re-setting the IMAP-account has not solved the issue, but i see you haven’t from your last reply.

As @Gary says that will normally fix any issue like that. So hopefully that fixes the problem.

Thank you both for continued advice.

Deleting the account and setting up a new one does not seem to make a difference.

I did so this time on a different notebook without any “history”.

The calendar still does not provide access to my GMX calendar.

The calendar address is given as https://kalender.gmx.net/begenda/dav/users/

Which seems to look right; doesn’t it.

Though I do wonder, if /users/ shouldn’t be spelled out with my own user name / mail-adress.

One more piece of information – and I only thought about checking this right now: The address book does provide a GMX-folder.

It is accessed via https://carddav.gmx.net/.well-known/carddav/

Therefore - and as a summary of the error-reporting:
Access to GMX-Mail and GMX-Contacts/Adresses works fine.
Access to GMX-Calendar does not and is only local.

That is correct.

You might want to contact GMX and see if there is an issue with your account.

I shall do so. Thanks for support!

On the other hand - why don’t I start a new post inviting feedback to the topic of “GMX calendar does not copy to / synchronize with emClient”?!

Better not to duplicate posts.

Got it.
Shall delete that second one.
Thanks for the advice.
Had hoped thereby to catch more of the GMX-experienced members.

@cyberzork + @Gary

Will you believe it?
“MyCalendar” is back.
Wonder what happened.
It may indeed have been a GMX issue.

P.S.: Cannot find my 2nd post anymore. Did anyone clear that away already?

That’s great your calendar is back :+1: Quickly backup via “Menu / Backup” while its working.


What version of Windows are you using?

If you are on the Windows Insider program, or using Windows 11, there may be some issues. I installed Windows 11 (22000.51), and CalDAV fails because of some Microsoft bug. You will need to give them some time to work it out.

Appreciate your foresight!
I shall keep that topic in mind.
And am happy that the current issue got solved by itself … :slight_smile:

1 Like