Emails to myself from emclient all go to Junk

Pretty bizarre just started on ver 9.2.2093 on Win11

It is fairly normal for email providers to do that, as they consider messages with the same from and to address to be spam.

Hey there, this just happened after moths of using your email client. It never happened with other email clients I used. I use gmail, If i go directly to gmail and send the message, this does not happen. Is there a way in eM to whitelist?


No, eM Client doesn’t have any spam detection ability, so has no whitelist to prevent messages being incorrectly detected. But this is being done by the server, so you will need to see if there is some way to disable it in the settings in webmail.

Or did you perhaps blacklist your own email/domain in eM Client? That is the only way eM Client can move the message to Junk. Go to Menu > Settings > Mail > Privacy > Blacklist > Manage Blacklist. See if your address or domain is in the list and remove it.

1 Like

Thanks Gary, that was it, somehow I did add me to the blacklist. Thx