Emails either disappear or take long time to reload

I cannot find any rhyme-reason for this and it is a major source of frustration.
From other conversations with similar issues, I think it has something to do with POP/IMAP settings, but not exactly sure how to solve it.

I cannot see where in EM Client I can change my POP/IMAP settings, and even if I could see where to change IMAP/POP settings I’m not sure what I would change them to.

My sense (and I’m not 100% confident) is that I have IMAP settings for my eM Client on my home computer, and that when I access emails on other devices (cell phone and work computer when away from home) this somehow causes eMClient to re-synch and sometimes it re-synchs with all my messages and often it doesn’t—in either event my messages are not appearing for a long time.

My worry if I set eM Client to POP is that then the messages will be deleted from the server and therefore I will not be able to access those messages at work computer/from cell phone. 

Given that the above has been a major head-ache, plus other issues with eM Client (it’s spell-check is not as good as Outlook, i.e. it doesn’t give alternatives for “doesn;t” with a semi-colon, and  can’t search for recipients that I’ve sent to (there’s probably a work-aroudn for this as well—but why need a work-around? Shouldn’t that be a straight forward  Search function?) I’m definitely not about to make EM Client my service on my cell or at work.

Hello Dale,
sorry for the late reply, seems like your post got buried a bit and I am sorry for overlooking it.
You cannot change the mail protocol through the setting, you need to set up your account anew.
If you are not happy with the automatic setup of your account, you can go to Tools>Accounts and in the New Account window choose Mail>Other instead of the automatic setup.
Here you can manually input your mail servers and choose if you are using a POP or IMAP protocol.

As for the POP setting, many servers provide the option to save the messages on the server (eM Client has an option for this in the POP settings too) but it will always be more tricky than IMAP and it is not recommended if you check the same mail on more devices, as it would not download the messages you read on other devices first.
You can see what protocol your mail currently uses in the Tools>Accounts settings of your account - if its a POP/IMAP it will have a tab for it, or it could be set up as Exchange or AirSync. Depending on your account type on the server.

As for the spellcheck, we indeed don’t have autocorrect feature. But the recipients is just part of the setting, not a workaround - enable ‘Store composed mail recipients for suggestion’ in Tools>Settings>Mail>Compose.
I’m sorry that you find this inconvenient as being disabled by default, but I’m afraid that’s just a difference in opinions, seeing as other users would prefer to not have the hint window for the recipient field crowded by addresses they no longer plan too contact