Email stuck in limbo

I recently sent an email and I made a mistake and had a period (.) at the end of the recipient’s email address. Of course the email could not go through. Now, I keep receiving an error saying “At least one email is invalid…” eM Client continues to try to send this message over and over again and I keep receiving the same error. I have checked my sent and outbox folder so maybe I could delete the email with the incorrect address. The email is no where to be found and this notification is driving me crazy. The only way I can receive email now is by clicking “receive only” because the regular way triggers the error message again. This is making eM Client almost unusable at this point. Please help me…

This is the error that I am receiving.

Capture

See if your failed email is stuck in the “Local folders” Outbox “at the bottom left” of eM Client.

Usually stuck or failed emails go there where you can delete them.

To enable local folders in eg: eM Client for Windows, click “Menu / Settings / General” and check the box, “Show Local folders".

image

Note: If nothing in eM Client local folders outbox, then it’s just normally your SMTP server which is just constantly trying to resend your email and eventually will stop notifying you.

You can allways contact your SMTP server tech support staff who can advise how long your specific SMTP server will try resending failed email.

THANK YOU!! The local outbox folder was hidden and that’s where the email was stuck. I deleted it and now all is well. Cheers!

1 Like