Email signature not being inserted properly on some replies

When I send a new email, my signature works fine - it is in colour and has my logo. When I reply (to only certain people) my signature looses colour (text) and the image no longer shows up. Not sure if this is a setting or if it is because of how the other person emailed me. 

I tried deleting my signature off the email and re inserting it on the individual reply but it still comes up the same.

I have multiple accounts and on all of them it does the same thing to certain emails.



Morgan, this sounds like an HTML/Text format matter. Email clients tend to have an option for whether to compose in HTML or plain text (which doesn’t support colour or images, amongst other things). I guess some vintage or simple clients may only support plain text, which is the lowest common denominator.

In eM Client’s Settings, Mail, Compose dialog, you can choose whether to compose in HTML or plain text (HTML defaults I think), and how to compose a reply to a plain text email (defaults to the attribute of the email in question, I think). Choose HTML for the latter and you should be able to add your signature successfully. At an individual reply level you can go to Tools, Format and pick HTML.

All this presupposes, of course, that the email client of the sender supports HTML. If not, then your stylish signature won’t display anyway!

Hello Morgan, as Neil implied, this might be due to the message being formatted as plain text, eM Client by default choses the format automatically based on the received message, can you please make a screenshot of the issue and submit the screenshot to us here on the forum?

Also try to navigate to Tools > Format > HTML in the new message window to see if you’d be able to include your signature in it’s pre-set formatting from the Signature settings.

Hope this helps.