Email Message take too long to load after Selecting

Email takes too long to load when selected. This happened after upgrading to Version 7 Currently I am on version 7.0.26356.0
I am using MS Exchange ActiveSync

Hello Elias,
make sure to download the latest installation file from our website, the current version is 7.0.26482.0
As for the speed, version 7 has a new database structure, so this could be just the initial synchronization that takes a bit longer. Or have you noticed this behaviour for more days?


Dear Olivia,
Thank you so much for your reply.
I have updated to the latest version and the problem is still there.
I have noticed this issue since few days. All my emails were downloaded the problem is when I click on an email to read, it is taking too long before it is loaded (It is showing blank, after sometime it shows the email body).

Thank you for your support.

I have the same problem. The message is downloaded but never seem to open when I click on it especially for messages that have already been read. current version is 7.0.26482.0

Forgot to mention this happens when I click on new messages that popup in the bottom right corner as well. current version is 7.0.26482.0

Same problem. Version 6 began to not open the body of an email, so i tried serveral settings for imap. now i’ve upgraded to version 7. it’s even worser !!!
what’s the reason for load only the subject and not the body ?

By default, version 7 initially only downloads the headers and not the body when the message is received. The body of the message is downloaded when you select it. You can have the entire message downloaded locally when by going to menu/tools/account/ select the imap tab and check “Download messages for offline use”. Note - depending on the volume of messages, the initial download could take a while.

GREAT ! That works !
Thank you.

Going to try as well

Thank you Jay for your comment, My email settings are exchange ActiveSync with no IMAP option. Any idea if I can do the same with ActiveSync. I tried to figure out the same option under exchange web services tab in the Account settings but couldn’t find it.
The funny thing is when I select work offline, the emails load as soon as I click on the message from the message list :slight_smile:

Not sure about Exchange, as I don’t use it.  Sorry…

This did not work for me on forwarded messages, the header comes in and you have to wait a while for the body of the forwarded message.

I am running version 7.0.27943.0 and the delay almost makes the client unusable. I am evaluating EM Client to replace outlook but so far its failing.

I have the same Problem, Client takes too long openung a mail. If I disable Virus scanner all is running fast. I tried it with McAfee and Bitdefender. always the same. In Version 6 it runs fast. o Version 7 is not usable!!!

I’ve had this same problem, in both 6 and 7, with IMAP for Gmail. Jay’s solution seems to help.

Some further explanation of this “download for offline use” function might be helpful.

I use Kaspesky and Norton. No issues. Don’t know much about but defender but I know mcafee is a dog. If Emc runs well without them, I would contact both and find out what tweaks might work.

same for me.
Wanna changue from thunderbird but it is useless if I can not read the mail

Olivia - I have this issue too and it is also NOT downloading for offline use even though I have the box ticked in the IMAP settings.  How do I raise a support ticket?

Thanks, Justin Milligan.

It may be some time before you get a response from Olivia.

Until then, if you have a Pro License you can open a support ticket at

Interesting solution… but it works! I was just about ready to give up on eM Client because of this problem (dare I say design flaw). Fortunately, Jay’s solution fixed the issue for me. I can’t believe anyone would design an email system where you have to wait 10-20 seconds to view the contents of a message… and that’s on a network with 100 mbps.