email duplicates in 'All inboxes'

all inbox emails have started showing twice in the smart folder ‘All inboxes’ - I am using V7 and this is supposedly fixed - can anyone help?

Hi Martin,

By any chance, is it possible that you have:

  1. A rule set in eM Client that would copy an incoming email to another email account’s inbox OR A forwarder set on the server?
  2. An account set twice in eM Client?

Please check it in Menu > Tools > Rules and Menu > Tools > Accounts respectively.

Russel

Russel,

Hi, so I have identified a bug in your system and have managed to get around it. The story is as follows:

two days ago I deleted a little used email account. having done this em Client for reasons unknown (a bug?) loaded up a google page and requested that I confirm access to my master email account (where 95% of all emails are received). I couldn’t see why this should happen so I ignored the request and noted that I was still receiving emails from that account.

one day ago em Client continued to pester for me to confirm access via Google, so I gave in and confirmed. From that point on every incoming email related to my master account was duplicated in All inboxes, although not in the specific inbox. I checked and only one account for my master email address was listed and I have implemented no rules (nor were there any present when I checked)

I tried deleting and re-installing the master account but to no avail.

So, I had a hunch as to what was causing the problem. So I reverted to the backup from the day before. As expected the backup having been implemented, em client asked yet again, via Google, that I confirm access to my master email account. But this time I rejected rather than accepted the request. This appears to have fixed the problem.

I conclude that deleting an email account triggered the request for confirmation of access, via google, to my master account and that by confirming access a ‘shadow’ account was somehow created which resulted in all emails related to that account, but not others, being shown twice in the All inboxes. By the way deleting either email deleted the other.

I hope this helps you find the bug!

Martin

I think there is no bug, but you had the account setup twice in eM Client. :slight_smile:

eM Client can’t setup an account without your knowledge.  Maybe you imported your settings from another client, then you added you account separately. Go to Menu > Tools > Accounts, and confirm that only one account is there.

Thanks for your feedback but I am an experienced programmer and I know it only displayed the accont in question once when it was displaying the emails twice because I checked.

The point is that it did tell me it was setting up twice, not on my instruction, but by displaying the google form for me to give permission, which I assumed was a re-confirmation, not a new account, as I hadn’t initiated adding a further account.

There is no such thing as can’t when one is dealing with complex software! Anyway, it is now fixed and if you are so certain it can’t be a bug then that is up to you.

The google form is the permission to setup 0Auth security when setting up an account. Once it is setup you will never see that form again unless you remove the app from your Google settings. 

Sometimes it pays to read what the form says! :wink:

I cannot speak as to the technology and what’s possible and what isn’t, but I too am having the same experience and can confirm some of the things Martin said. 

Tonight I received an email notifying me of the new version of eM Client. I followed the link and downloaded and installed version 7.2.33939.0. After the install, a window popped up asking me to log in to my Google account, which seemed reasonable since I have a gmail account setup in eM Client. I clicked to log in and went about various other business that I was engaged in. After a little bit, as I closed a couple other windows where I had been working, I found another window waiting for me asking for access to my Google account. I was in a hurry and had other things on my mind so I just clicked to allow, though as I did, I was wondering why the eM Client install would ask me twice for access to my Google account. It was after that that I found all the messages in the “All Inboxes” folder were now duplicated.

I did follow Russell’s instructions above and have confirmed that my gmail account is only setup in eM Client once. However, just as Martin experienced, I have one copy of each message in my gmail account, but two copies in the “All Inboxes” folder. Based on Martin’s experience and mine, it appears eM Client is triggering the Google login and access permission process twice and from that point forward, our gmail messages multiply in the “All Inboxes” folder.

Did you try removing the account from eM Client, then adding it again?

Just now tried that. After deleting the account, I was back to only one copy of each message in the All Inboxes folder, but upon recreating the account, it again required me to login to Google to finish the account setup and now I’m back to duplicate copies.

If you delete the account from eM Client, there should be no messages in the All Inboxes folder.

If there are, then it means that either you have the account setup more than once, or you have a copy of the messages in Local Folders.

I just repeated the process and here’s how it went.

I went to Menu > Tools > Accounts, then highlighted my gmail account, clicked the trash can icon and deleted it. This removed the duplication and left me with one copy of each of my gmail messages in the All Inboxes folder. The gmail account is no longer listed in the left panel displaying my various accounts. The “Local Folders” inbox is empty.

When I click to create a new message, the gmail account does not appear as an option for sending from.

However – I went to my Yahoo account using their web mail interface and sent a message to my gmail account from there. The message arrived in the All Inboxes folder.

Evidently, there is a second copy of the gmail account somewhere in eM Client that is capable of receiving messages, but it doesn’t show up to send messages from or to be able to delete it from the list of accounts.

Can you give a screenshot of Menu > Tools > Accounts.

I confirm everything that Bob Peck says, simply telling us it can’t happen or that we are doing something wrong  doesn’t cut it - it does, there is a bug!

1 Like

I agree Gary, Martin Wyatt - there is a bug!

1 Like

I repeated the experiment. Above is a screen capture with the gmail account deleted. Notice that my gmail account is not listed in the accounts section or in the left panel. My Agenda section on the right is also empty. I went to Yahoo and sent myself another message and it appears at the top of the inbox. The three messages from eM Client are all different replies to this thread.

The GMail account is still there:

That’s a different gmail account that was created for a special event last year. My main gmail account, the one that’s duplicating, is rwpeck59@gmail.com. I setup that account again now and will include a new screen capture below.

Please check that you don’t have any forwarding set on your GMail account. 

Something you can try if that is not there is to remove both GMail accounts from eM Client, then set them up again. First the rwpeck59 one and see if the issue is still there. If it is not, then setup the other one.

If that does not help, as a Pro License user, please open a support ticket with eM Client. They will be able to assist you further.