EM Client will not send mail through SMTP

Really disappointed with this new software. It took me almost an hour to configure IMAP/SMTP with the standard settings. In the end it required a ridiculously-specific combination of settings. Then I had to “Diagnose” the settings, and when they failed I had to “Fix” them. Failure to do everything in a very specific order resulted in failure. I thought it was working at that point, because I received some new mail in EM Client.

Then I tried to compose mail. It did not work. All of my SMTP settings are correct, and I’ve gone through the Diagnostic crap a million times. I cannot send a single message. In my “Local Folders” it lists 4 outgoing e-mails. Even though I have "Fix"ed my SMTP settings multiple times successfully, SMTP always shows as “Failed” when I go to the diagnostic page. "Fix"ing it again at that point does nothing. When I try to close the client, it informs me that I have 4 e-mails in my outgoing folder waiting to be sent.

Not sure why this mail client has so many problems versus every other mail client in existence, but I’m hoping someone can help me out here.

If you be more specific I am sure someone will help.

What email service provider are you using?
What server host settings are you using for SMTP?
What port are you using for SMTP?
What “security policy” are you using?

I am using eM Client with 4 email service providers and all work perfect.

Thank you for your reply.

I am using my hosting e-mail through Namecheap. These are my mail settings (Namecheap has confirmed these and they work fine through Thunderbird):

Host: server61.web-hosting.com
Port: 465
Security Policy: Force Usage…

Server Requires Authentication (checked)
Use these Credentials (verified and re-entered several times)

Try port 587

And also try “SSL/TLS if available”

I tried that and got the error again in the Diagnostic thing. I clicked Fix and went through authentication, etc., and it said it was fixed, and then immediately popped up with this:

http://gyazo.com/e032171ad2f243448c31…

Please try “SSL/TLS if available” and change port to 587.

Are you able to receive emails with this “server host”

The port number did not work. The “if available” option is one that I tried before, but I tried it again and I still am unable to send e-mails.

To be honest, my reason for using eM Client had to do with Yahoo Mail POP3 access, but I have since discovered that the new Yahoo Mail offers this for free (used to be only for Plus members). I really appreciate you trying to help, but I think I will save myself some time on this one and just stick with Thunderbird. Thank you for your assistance.

For the record, I am able to receive e-mails fine with my current settings, from the host mentioned above.

Hi, 

Can I ask you for SMTP logs? Tools - settings - advanced, check SMTP, apply and restart eM Client. 
then make same steps which leads to your issue and after that send logs… to galis@emclient.com together with this topic’s URL in subject. 

then you can turn logging off. 

with regards 
Jan