eM Client v5.01 ERROR: RCPT not accepted from server: 530

I can receive but not send. I’m using Uverse High Speed. I checked and rechecked my settings, changed the password. Everything was working till 3/23/13 when MS updates were completed. I’ve shut down the firewalls, anti virus and reconfiged the router to allow all. I’ve run the telnet check on port 25 and it indicates failure.

SMTP = smtp.sbcglobal.yahoo.com

Any suggestion will be appreciated. Thank you for your time and consideration

I was also having the same problem. I tried a bunch of stuff. I changed the smtp port to 587 and everything now works. Hope this solves your problem.

Your tip solved my problem. I’m a stroke victim and email is my only practical contact to the outside so it’s very important to me. My IPS is AT&T who no help whatsoever when it was them who blocked port 25.

Again thanks ever so much!

Glad I could help. I don’t think the problem is an ATT/SBC issue. I could telnet to smtp.sbcglobal.yahoo.com 25 from a server at work. I think the issue is a Windows 7 problem. A lucky internet search provided the new port number. Nothing from ATT/Yahoo pointed to port 587.