eM Client trims empty lines in certain cases


Since the latest update (I think), eM Client has been occasionally trimming all empty lines upon sending the email, resulting in very ugly emails which are a bit embarrassing, So for example sending this:

Hi Ms. Doe,

I would like to thank you for your email.

Becomes :

Hi Ms. Doe,
I would like to thank you for your email.

I haven’t found a consistent way to reproduce this, but maybe the developers would know where to look at?

Thank you.

I tried to reproduce it, but was not successful. Not once.

If you think this is because of the recent update, then you can uninstall eM Client and download the previous version from the Release History.  When uninstalling eM Client, you will be asked if you want to delete the database directory. If you choose not to delete the database, all your data and settings will be there once you have downgraded.

Hi Gary,

Thanks for trying out. I think I found a way to reproduce this.

  1. Open windows notepad
  2. Write something with a blank line in it
  3. Copy/paste it in a new email, as text (ctrl+shift+v)
  4. Send it
    You should be seeing the blank line trimmed in your sent mail folder and the received email.

Can you reproduce under those circumstances?

Yes, that is reproducible.

I tried the exact same thing yesterday, but did not paste as text. Even if you paste normally, then change the format to plain text, it does not seem to happen.

Best is if you have a Pro License, open a support ticket so that the developers can fix it.

Hi Gary,

Thanks for taking the time to confirm this. I don’t have a Pro license so this is why I posted it here.

Anyway, the issue is reported and reproducible, so it’s here if the developers read this thread and want to fix this.

Thanks again.

I will open a ticket so they have the issue logged.

This issue has finally been resolved in beta 8.0.1194, which should soon be available in the Release History.