eM Client stuck in Italian

I went to settings -> Spell-Checker and I unchecked “Use automatic spell-checker” then pressed “Apply”.  eM Client then switched to Italian.  Underneath the check box, by “language” it says “Application Language” (which is English … how do I change that?).  I tried changing that to the other options, including “English (United States)”, but that did nothing.  I tried all other settings and combinations and I can’t get it out of Italian language.

I have Windows 10, 64-bit, and have just downloaded the new version (version 7.0.27943.0).  I’m about ready to revert back to the old version that doesn’t have problems like these.

Please advise.

Hello Nilbert,

You can change the application language in Menu ->Tools ->Settings ->General ->Language.

The options in “Default Spell-Checker Settings” aren’t used unless the box “Use automatic spell-checker” is checked. When you check it, you can select your preferred option.

If this doesn’t help with your issue, please post a screenshot of your settings so we have a better idea of what’s happening.

Thank you,