em Client not sending CalDAV to proper port

Problem when using em Client as CalDAV client, and configured for a specific port. There is a problem when trying to update a Calendar event or deleting it. It sends to port 80 instead of the configured port. It should send it to the configured port , similar to sending PROPFIND, REPORT, PUT for creating a new event.

Hello, not quite sure what you’re referring to, note that Port 80 for example is used by the application for communication with the licensing server, so this port has to be open in order to connect to the server and check your license. Are you having some issues with the application using your CalDAV account on Port 80? You should be able to specify the port in the server address used by eM Client to connect to your server, like so:


Hope this helps,

I have configured it to use port 8376, and it is working fine initially.
But when updating or deleting an event, it is sending to port 80, while the configuration is port 8376
I am using version  6.0.22344.0

Hello Fuad, I’ve checked with our developers and if the port is setup in the account settings in eM Client, new items should be synced on that port as well as deleted, however if your server is setup to run on unspecified port, all older items may be setup to run on specific address (for example on Port 80) - so in that case you would require to force re-sync your folders with the new setting, and make sure that the server is not setup to run on a different port (80) or on an unspecified port - however once port is specified in your account settings, you should no longer have an issue with this.

Try to run the repair on your calendar folder(s), by right clicking the folder in the left pane, navigating to it’s properties and selecting the Repair option in the properties.

If the issue persists, please let me know so we can collect additional logging data from you.