eM Client hangs on opening every time

Hi All,

I am a new user to eM Client and also evaluating the software for IT clients.

The first install on my own PC for me to get used to the software did not go swimmingly and I was unable to run any v7.1 client as they would all hang in the same way. I installed v7.0.27943.0 and it worked first time! I’ve set it up and configured ok with some useful assistance from Gary Curtin and now need to get onto the latest version to address some issues.

I have installed the latest release, v7.1.32561.0 on another PC which worked first time and transferred over my config and db’s and all is working ok.

Back on the first PC, I uninstalled v7.0 and deleted the renamed the eM Client folder in the Roaming Profile so it creates a completely fresh out of the box install and this crashes in the same way as all the previous tries of v7.1 clients.

The process is exactly the same each time:

  1. Open the software and get asked to choose a Theme

  2. Prompted to setup an account and import data from Outlook which is skipped

  3. Main window opens and looks normal with the welcome email in the Local Folders

  4. Mouse over the window and see the Win 7 “Donut of Death”. Nothing happens no matter how long you wait.

  5. Click the “X” to close the window and here is the information displayed:

  A problem caused this program to stop interacting with Windows.

Problem signature:
  Problem Event Name: AppHangB1
  Application Name: MailClient.exe
  Application Version: 7.1.32561.0
  Application Timestamp: 5ad722ee
  Hang Signature: dc39
  Hang Type: 0
  OS Version: 6.1.7601.
  Locale ID: 2057
  Additional Hang Signature 1: dc392ff541ee8959272314d71f0ea2f9
  Additional Hang Signature 2: e6da
  Additional Hang Signature 3: e6da922500204e6a7b74d158e90f1ad5
  Additional Hang Signature 4: dc39
  Additional Hang Signature 5: dc392ff541ee8959272314d71f0ea2f9
  Additional Hang Signature 6: e6da
  Additional Hang Signature 7: e6da922500204e6a7b74d158e90f1ad5

Read our privacy statement online:

If the online privacy statement is not available, please read our privacy statement offline:

Both machines are running Win 7 x64 with the April Windows Update Rollup installed. They both have Kaspersky AV although the install was tried with AV completely uninstalled (was changing to KAV from Bitdefender anyway) with no difference.

Can anyone offer any assistance please with how I may debug this issue as it is obviously related to a specific machine with this software as all the other apps work just fine? Possible thoughts are:-

Does v7.1 need a specific .NET or VulkanRT or something?

Is there an Update Check or Telemetry Feedback going on straight away and failing to get a response?

There are 2 log files created in [Roaming Profile]\eM Client\Logs\ but both are empty, are there any other logs to check?

Any help would be much appreciated! Thanks,


eM Client does require .NET Framework, though I was not able to find what the minimum requirement is. On Windows 10 it seems to be fine out of the box without any updates needed. I am using 4.0.21 if that helps. To find out which version you are using, run the following at the command prompt

wmic /namespace:\root\cimv2 path win32_product where “name like ‘%%.NET%%’” get version

That is the the correct log directory. The WM Tracing log is the one that the developers are usually interest in when something goes wrong.

Thanks for the pointers, Gary.

Both PC’s have v4.7.1 installed with the April Update giving the output of the command as v4.7.02558

The logs folder has a WM Tracing [Date][Time].log file for each time I open the app and a cef.log file but all are 0KB. There is an SQLite.log file with entries in but it is only where it has to rebuild the “empty” db upon opening each time which it does successfully.

Both PC’s have the same services running (barring a few odd driver differences) and are patched the same. All other apps are running fine including v7.0 of eM Client so it has to be due to a change implemented in v7.1 either doing a check of something on opening or needing a version of a 3rd party software or possibly a dll/permissions issue for a file/folder that isn’t referenced in v7.0?

Is there any documentation on the processes during opening or differences between v7.0 and v7.1? As this is only for testing and is currently unlicensed I guess there is no support from the company either?

The .NET requirement is definitely lower than 4, so that can’t be it.

A new WM log is created on start and usually remains at 0KB until the application is closed. Then the data is written and it should be about 5KB.

The change log on the website is very basic and lists only a few of the changes, so it is difficult to know what changed. I think one thing that did change from 7.0 to 7.1 was the database structure. Maybe someone can confirm that.

Unless Russel or Olivia comment on this thread, it is unlikely that you would get any company support. Don’t know what else to suggest. ;-(

Thanks for the reply.

Regarding the db structure, when I installed the v7.1 onto the second PC and copied the db folder in there was no obvious upgrade or change to the db and its size did not change either. However, the change may have been subtle. As it is a simple db of files in an ordinary folder structure that gets automatically created by the app on opening (if not existing already) it will have the correct layout and permissions required so I can’t really see it being the issue.

I’m kind of stuck now without any more information about which avenues to explore. It is mighty frustrating too as I need to get on and this is a key stumbling block. I don’t want to have all that time and effort already put into learning this solution wasted but I can’t keep hoping. I cannot recommend this solution to clients either as if I can’t get it to work consistently then businesses would not want the risk!

I think there was some change made to the way 7.1.32561 (which has since been removed from the download page) opened 7.0 databases.

Interesting. Unfortunately, whatever the reason for them rescinding the update, it probably isn’t the issue I have as it is all versions of 7.1 that won’t run on this PC!

Ah! I think I’ve cracked it!

It is my Fingerprint Reader system tray application called “psqltray.exe”. The app runs on boot and allows me to use fingerprints for logins for pretty much all authentications and plugs into the Win 7 Windows Biometric Framework. After making sure there was nothing opened or doing anything in the background, I used ResMon whilst I opened the eM Client and I noticed disk activity for “psqltray.exe” to the C:\Windows\assembly.NET 2.0… folder which didn’t make sense as it shouldn’t have been doing anything. Killed it and voila!

So it is something peculiar to v7.1 of eM Client with the Fingerprint Reader application, Authentec Protector Suite, as they both work fine without each other. Unfortunately I’m running the last release of the Protector Suite as the company that made it was bought by Apple and it became Touch ID. I also can’t do without it as it is a great piece of kit and I have unique passwords for every website so most of them are too hard to remember!

All is not lost though as it indicates this issue with eM Client is confined to my daily use PC (which is the first place I tried it!) with an oldish peripheral and is probably unlikely to occur in another install environment, so I would feel reasonably confident to recommend it to my clients.

I now need to find another password management app that takes fingerprints to replace my Protector Suite.