EM Client: Email stuck in outbox

Good day EM client,

Referring to the log below, SMTP is connected, however, email will be stuck in the Outbox, sometimes the email can be sent out, but still shows that it is stuck in the Outbox. Is there any fix for this?

=====================
11:41:28 PM ips1@perundingyaa.com.my [SMTP] MailClient.Accounts.SocketException: Sending messages failed due to the following reason:
“Unable to read data from the transport connection: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond…”
at MailClient.Protocols.Smtp.SmtpSendCommand.Execute(WorkerStatus status)
at MailClient.Commands.Command.Process(WorkerStatus status)
EnqueuedStackTrace =
at MailClient.Protocols.Smtp.SmtpAccount.<>c__DisplayClass3_0.b__0()
at MailClient.Protocols.Common.AccountBase.RunIfOnline(Action actionIfOnline, Action actionIfOffline)
at MailClient.Protocols.Smtp.SmtpAccount.SendAsync(IEnumerable1 items, Action1 sentItem, Action1 completed, CancellationToken cancellationToken) at MailClient.Accounts.BindingAccountBase.SendInternal() at MailClient.Accounts.BindingAccountBase.Send() at MailClient.UI.Forms.formSendMail.<>c__DisplayClass436_4.<Send>b__6(CancellationToken cancellationToken) at MailClient.UI.LongOperationService.<>c__DisplayClass7_0.<MailClient.ILongOperationService.InitOperation>b__0(CancellationToken ct) at MailClient.UI.LongOperationService.<>c__DisplayClass13_01.<b__0>d.MoveNext()
at System.Runtime.CompilerServices.AsyncMethodBuilderCore.Start[TStateMachine](TStateMachine& stateMachine)
at MailClient.UI.LongOperationService.<>c__DisplayClass13_01.<InitOperation>b__0() at System.Threading.Tasks.Task1.InnerInvoke()
at System.Threading.Tasks.Task.<>c.<.cctor>b__277_0(Object obj)
at System.Threading.ExecutionContext.RunFromThreadPoolDispatchLoop(Thread threadPoolThread, ExecutionContext executionContext, ContextCallback callback, Object state)
at System.Threading.Tasks.Task.ExecuteWithThreadLocal(Task& currentTaskSlot, Thread threadPoolThread)
at System.Threading.Tasks.Task.ExecuteEntryUnsafe(Thread threadPoolThread)
at System.Threading.Tasks.Task.ExecuteFromThreadPool(Thread threadPoolThread)
at System.Threading.ThreadPoolWorkQueue.Dispatch()
at System.Threading._ThreadPoolWaitCallback.PerformWaitCallback()
GUIStatus_Exception_Reported = True

A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond…

This can be a few reasons.

Your smtp server currently may have an “actually smtp sending problem” and no mail is sending for anyone via clients. So check with your mail server guys via their website or phone incase there is.

You may have “outdated or incorrect smtp settings” in eM Client. So dbl-check again with your server support the correct settings and also update this thread what those are in your SMTP Tab.

Or you may have a program interfering or blocking you sending mail after connecting. So if you have any optional eg: Firewall / Security, Antivirus programs, VPN’s etc try disabling those to test.

Lastly this may also be related to your Router or Computer where they may just need a “Reboot”. Sometimes IP address’s (Particularly Dynamic) after a long period of time go stale and just don’t work properly and you need to reboot the routers and any computers connected to them. So try a reboot.

Hi Cyberzork,

Appreciate the prompt reply.

Actually, we are the server owner of this email address @perundingyaa.com.my

  1. Our SMTP has no issue

  2. We have tested a few different email clients via Outlook / Thunderbird / /Apple Mail worked without any issue.

  3. Surprisingly, only EM client is unable to send out any email.

  4. The issue is pretty weird, SMTP shows connected, no issue with account configuration, then sometimes EM client is able to send out the email, the recipient received the email, but still shows stuck in Outbox. From our side, we are unable to trace any error on the server mail log.

In this case, is your side able to advise any alternative, below is the account settings we have set for ips1@perundingyaa.com.my

===========
IMAP Host: sme13.small-dns.com
Port: 993
Security Policy: Use SSL / TLS on special port (Legacy)

SMTP Host: sme13.small-dns.com
Port: 587
Security Policy: Force Usage of SSL/ TLS

Note: These settings shows OK under the Diagnostics tab

Below is the recent log that we have tested today

12:50:13 PM ips1@perundingyaa.com.my [SMTP] MailClient.Accounts.SocketException: Sending messages failed due to the following reason:
“Unable to read data from the transport connection: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond…”
at MailClient.Protocols.Smtp.SmtpSendCommand.Execute(WorkerStatus status)
at MailClient.Commands.Command.Process(WorkerStatus status)
EnqueuedStackTrace =
at MailClient.Protocols.Smtp.SmtpAccount.<>c__DisplayClass3_0.b__0()
at MailClient.Protocols.Common.AccountBase.RunIfOnline(Action actionIfOnline, Action actionIfOffline)
at MailClient.Protocols.Smtp.SmtpAccount.SendAsync(IEnumerable1 items, Action1 sentItem, Action`1 completed, CancellationToken cancellationToken)
at MailClient.Accounts.BindingAccountBase.SendInternal()
at MailClient.Accounts.BindingAccountBase.Send()
at MailClient.Accounts.AccountManager.SendInternal(IAccount account)
at MailClient.Accounts.AccountManager.Send(IAccount account)
at MailClient.UI.Forms.formMain.accountSend_Click(Object sender, EventArgs e)
at System.Windows.Forms.ToolStripItem.RaiseEvent(Object key, EventArgs e)
at System.Windows.Forms.ToolStripMenuItem.OnClick(EventArgs e)
at System.Windows.Forms.ToolStripItem.HandleClick(EventArgs e)
at System.Windows.Forms.ToolStripItem.HandleMouseUp(MouseEventArgs e)
at System.Windows.Forms.ToolStripItem.FireEventInteractive(EventArgs e, ToolStripItemEventType met)
at System.Windows.Forms.ToolStripItem.FireEvent(EventArgs e, ToolStripItemEventType met)
at System.Windows.Forms.ToolStrip.OnMouseUp(MouseEventArgs mea)
at System.Windows.Forms.ToolStripDropDown.OnMouseUp(MouseEventArgs mea)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
at System.Windows.Forms.ToolStrip.WndProc(Message& m)
at System.Windows.Forms.ToolStripDropDown.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, WM msg, IntPtr wparam, IntPtr lparam)
at Interop.User32.DispatchMessageW(MSG& msg)
at System.Windows.Forms.Application.ComponentManager.Interop.Mso.IMsoComponentManager.FPushMessageLoop(UIntPtr dwComponentID, msoloop uReason, Void* pvLoopData)
at System.Windows.Forms.Application.ThreadContext.RunMessageLoopInner(msoloop reason, ApplicationContext context)
at System.Windows.Forms.Application.ThreadContext.RunMessageLoop(msoloop reason, ApplicationContext context)
at System.Windows.Forms.Application.Run(ApplicationContext context)
at MailClient.Program.<>c.b__169_1()
at System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor, Boolean wrapExceptions)
at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
at System.Delegate.DynamicInvokeImpl(Object[] args)
at System.Delegate.DynamicInvoke(Object[] args)
at System.Windows.Forms.Control.InvokeMarshaledCallbackDo(ThreadMethodEntry tme)
at System.Windows.Forms.Control.InvokeMarshaledCallbackHelper(Object obj)
at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state)
at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
at System.Windows.Forms.Control.InvokeMarshaledCallback(ThreadMethodEntry tme)
at System.Windows.Forms.Control.InvokeMarshaledCallbacks()
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
at System.Windows.Forms.ContainerControl.WndProc(Message& m)
at System.Windows.Forms.Form.WndProc(Message& m)
at MailClient.Common.UI.Forms.BaseForm.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, WM msg, IntPtr wparam, IntPtr lparam)
at Xilium.CefGlue.Interop.libcef.run_message_loop()
at MailClient.Program.Main(String[] args)
GUIStatus_Exception_Reported = True
12:50:13 PM ips1@perundingyaa.com.my SMTP Connecting: To ips1@perundingyaa.com.my
12:50:14 PM ips1@perundingyaa.com.my SMTP Connected: To ips1@perundingyaa.com.my
12:50:14 PM ips1@perundingyaa.com.my SMTP Sending messages

Hi Cyberzork,

I think we managed to source the issue.

Thanks for your assistance.

Have a good day sir. :slight_smile:

1 Like