eM Client does not restore its location on a secondary monitor.

I use Windows 7 with 2 monitors. eM Client is on a secondary monitor. When I close it and start it again its location is not restored. It is on the secondary monitor but not at the location is was closed.
The same problem exists on Windows 8.

Posted the same problems half a year ago. Was never fixed.

Does it happen only to eM Client application? Can you try to simulate this issue with Internet Explorer?

Internet Explorer works fine.

I just found out eM Client doesn’t maintain its location when it’s moved using the Windows button and arrow keys. That’s what I always use. Windows-Left, Windows-Right, etc.
When I move eM Client manually its location is stored.

Thank you for pointing this out - we were able to simulate this issue and will try to fix it as soon as possible.

I had the same problem with Win7 on 3 monitors, EM 5 release seems to have fixed it for me. Thank you, it was really a pain. :slight_smile:

Solved? Just installed an update, 5.0.17595.0, but the problem remains.

Steps:

  1. Find a pc with 2 monitors.
  2. Start eM Client
  3. Move it to the secundairy monitor using Windows + Left buttons.
  4. Close the application.
  5. Start the application.
    Result: Right location, wrong height. It’s 3/4 of the height is was when the application was closed.

Wondering if this could be a local issue for you, I have not had an issue with this since the update. Been working perfectly on four monitors.

Does it happen only to eM Client? Can you try to simulate this issue with another application?
Please inform me of the result.

Yes it only happens with eM Client. The steps above can be used to reproduce the issue on Windows 8. Using the Windows + Left buttons is crucial. When I manually move the application to the desired location, the location is restored when I restart the application.

Very strange - with the latest version I am unable to simulate it on my computer but we will keep trying …

While I know this is an old topic, I am experiencing this issue with v 6.0.19714.0 on Win 8.1 X64 (single monitor).

It is ONLY when using the Windows- snap to feature. Manual positioning is fine.

Interestingly, after snapping to a location, then adjusting the vertical size by any amount will remember the location. Not so on the horizontal.

Hi, this is correct behaviour. Aero snap does not remember position of windows after program which has created them is closed.

Jan