Duplicate emails in Gmail Unread folder (IMAP)

As Gmail apparently puts new messages both in All Mail and Inbox, they show in eM Unread folder twice. Why can’t the client see they are the same message and filter them? So far I have been using Opera mail client that handled that without any problems, i.e. no duplicates. Is there a setting in eM that I am missing? There is nothing that can be done on the Gmail side as disabling All Mail in IMAP doesn’t make sense and disabling Inbox is not possible. Is there a way to ignore Gmail Inbox on the eM side?  All Mail and Unread is all I ever needed.

Hi Pavel,
unfortunately eM Client synchronizes all items checked for the IMAP sync, so disabling All Mail is the only way to avoid seeing the new message twice for now.

Best regards,