Does not receive new messages

when I clicked “refresh”, the program shows “connecting” for a few seconds, but does not get new messages.

Are you getting any errors?

You will find them listed in Menu > Tools > Operations.

Thank you.
This is what is listed in the “log”:

22:07:04 Online state: changed to online due to NetworkAvailability 
22:07:05 velho [IMAP]  Synchronizing subfolders: For folder velho/
22:07:05 RIMON [POP3]  Connecting: To RIMON
22:07:25 velho [IMAP]  MailClient.Accounts.ConnectionException: Failed opening connection to server. —> System.Net.Sockets.SocketException: ‏‏ניסיון חיבור נכשל מאחר שהצד המחובר לא הגיב כראוי לאחר תקופת זמן, או שיצירת החיבור נכשלה מאחר שתגובת המחשב המארח המחובר נכשלה 213.151.32.73:110
22:07:25    ב-  System.Net.Sockets.TcpClient…ctor(String hostname, Int32 port)
22:07:25    ב-  MailClient.Imap.Base.Connection.<>c__DisplayClass43_0.b__0()
22:07:25 ב- MailClient.Imap.Base.Connection.Connect(Func`1 getStream)
22:07:25 ב- MailClient.Imap.Base.Connection.Connect(String receiveHost, Int32 receivePort, Boolean explicitSsl)
22:07:25 ב- MailClient.Protocols.Imap.ConnectionPoolEntry.Reconnect(CancellationToken cancellationToken)
22:07:25 — סוף רכיב מעקב אחר מחסנית של מצב חריג פנימי —
22:07:25 ב- MailClient.Protocols.Imap.ConnectionPoolEntry.Reconnect(CancellationToken cancellationToken)
22:07:25 ב- MailClient.Protocols.Imap.ConnectionPoolEntry.Connect(CancellationToken cancellationToken)
22:07:25 ב- MailClient.Protocols.Imap.ConnectionPool.AcquireConnection(Folder mailFolder, Boolean idle, Boolean forStore)
22:07:25 ב- MailClient.Protocols.Imap.ConnectionContext…ctor(ImapAccount account)
22:07:25 ב- MailClient.Protocols.Imap.Synchronizer.CreateFolderCommand.ExecuteInternal(WorkerStatus status)
22:07:25 ב- MailClient.Protocols.Imap.Synchronizer.ImapCommand.Execute(WorkerStatus status)
22:07:25 ב- MailClient.Commands.Command.Process(WorkerStatus status)
22:07:26 RIMON [POP3] MailClient.Accounts.SocketException: Error when receiving from account RIMON : ‏‏ניסיון חיבור נכשל מאחר שהצד המחובר לא הגיב כראוי לאחר תקופת זמן, או שיצירת החיבור נכשלה מאחר שתגובת המחשב המארח המחובר נכשלה 213.151.32.73:110
22:07:26 ב- MailClient.Protocols.Pop3.Pop3ReceiveCommand.Execute(WorkerStatus status)
22:07:26 ב- MailClient.Commands.Command.Process(WorkerStatus status)

Can you try disabling your anti-virus application, and see if there is any difference.

You can also check you have the correct settings for the account. Go to Menu > Tools > accounts and check: 

SMTP
Port 587 = Force usage of SSL/TLS
Port 25 = Use SSL/TLS if available
Port 465 = Use SSL/TLS on special port (legacy)

IMAP
Port 993 = Use SSL/TLS on special port (legacy)
Port 143 = Use SSL/TLS if available

POP3
Port 995 = Use SSL/TLS on special port (legacy)
Port 110 = Use SSL/TLS if available

These are the correct combinations of port and security policy. The underlined ones are the best option for security if your server supports them. SMTP port 465 was reassigned and should no longer be used for SMTP, though many mail providers still recommend and use it.

Thank you.
I will try this next time I have such problems (the problem is not constant, but it comes from time to time…)