Do not use "delete mails from server after N days" as default

After using wizard I hit sync button and my mails older then default 7 days gone. I have hundreds of them on the server, and now only few.
Only then I’ve opened advanced settings and changed this number of days.
This default is harmful and should be changed.

Ps. It also does not understand port as part of the url like