Delivery Receipt feature is not working

Delivery Receipt feature is not working. I don’t receive any sort of notification when I send an email with the delivery receipt feature selected.
I tried version 3.5.122xxx and then I upgraded to version 3.5.12491.0 and the delivery receipt feature is still not working. I also have it selected to attach a delivery receipt for all messages (Settings -> Receipts) but it is still does not work for any of my accounts.

The read receipt works fine, but it’s just the delivery receipt that isn’t working.
Is there any suggestions as to how to fix this?

It will be probably not eM Client issue but server’s one. What email servers do you use?

I have a account
The server type: POP3 Mail Server (incoming) and SMTP (outgoing)
Both the incoming and outgoing have the same host name: as specified by my service provider: Shaw

I’m not sure if this is what you are asking for or not.

On my Shaw webmail account ( I am able to select and receive delivery notifications and read receipts. But in this email client program I cannot receive delivery notifications. I don’t know if it makes any difference, but the webmail is on the Sun Java system.

Having same issue – never get any notification at all with Delivery receipt.

Hi, and does your recipients confirms your delivery receipt? I myself have this feature forbidden so noone who sends me emails will ever get delivery receipt.