Deleting Emails moves me to bottom of inbox view

Every time I delete an email from my inbox list the inbox list goes to the very first email at the bottom of the inbox. How can I stop this happening?

I would love an answer to this - its still happening even after the latest update.

Change the sort order of your Inbox back to sorted by Received > Descending.

Gary, thanks. But where is this in settings? Yesterday I could see inbox options but today after the upgrade I cannot seem to find it.

Thanks Gary, thats sorted it.

Martyn